0

Lately, I start getting this message when not shooting at maximum aperture with a Canon 55-250mm lens:

Err 01 Communications between the camera and lens is faulty. Clean the lens contacts.

I tried to fix the problem cleaning the contacts with a dry cloth but didn't work. Also tested with other cameras and the same result.

The error appears even if I have the lens at it's maximum aperture and change the zoom and that aperture is not the maximum for the new position.

Is there something else I can do other than sending it to the service center?

  • 1
    Different Canon lens. Exact same problem. photo.stackexchange.com/questions/85579/… – Michael C Jan 7 '17 at 2:25
  • 1
    Unless it is still under warranty, it will probably cost more to have it repaired+shipping both ways than to just buy another copy of the lens. Used or refurb copies of that lens are usually easy to find for about 1/2 the price of the newer STM model. – Michael C Jan 7 '17 at 2:30
  • 1
    You probably have a torn aperture ribbon cable inside the lens. Replacing that cable is the only option other than replacing the lens. – dgatwood Jan 8 '17 at 0:22
2

Probably not. But you could also try:

  1. Cleaning the camera contacts (probably not the issue, since it happens on other camera bodies).

  2. Set the lens to minimum aperture and take a few shots. Then switch back to max. aperture.

  3. Rebooting the camera to make sure it's not holding on to an old error state (i.e., remove all the batteries, lenses, external flash (if any is attached; and leave it alone for a day to let any capacitors drain, and then restarting the camera).

Chances are good, however, that if it persists, it might be a real hardware error.

Not the answer you're looking for? Browse other questions tagged or ask your own question.