1

I have a Canon EOS 1300D on which I have mounted a simple hot shoe adapter with sync port so I can connect it to my Jinbei Spark-II 300 studio flash.

Problem is the studio flash isn't firing. I have tried the hot shoe adapter in a NIKON D200 -> works, also in an older Olympus E-520 camera -> works.

Anyone any idea why it wouldn't work on the Canon EOS 1300D? Flash is enabled on the camera. I have tried both with Live view enabled and disabled.

  • Can you specify the exact hot shoe adapter you are using? – Michael C Dec 18 '16 at 20:55
  • What flash control menu options are selected on your 1300D menu? – Michael C Dec 18 '16 at 20:56
  • Hi, the hot shoe adapter is one from falcon eyes link – Philippe Leroux Dec 18 '16 at 21:29
  • On the 1300D (T6 in USA), all I can set is flash firing "enabled" and built in flash function settings (but they are not available when the hot shoe is in, all i can do then is enable the flash). – Philippe Leroux Dec 18 '16 at 21:31
  • Are you sure the adapter is properly seated on the hotshoe (pushed all the way in, so the sync pin on the foot meets the big contact in the center of the camera's hotshoe)? – inkista Dec 19 '16 at 0:37
0

It was a faulty connection on the adapter. Bought a different one which fit way better on the camera. Works like a charm. Thanks for all the help though!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.