5

I recently purchased a bunch of Flashpoint (Godox rebranded) flashes from Adorama. Here is a list of all the items that I've bought:

  • Flashpoint R2 TTL Transmitter for Canon (Godox X1T-C, firmware v18)
  • Flashpoint Zoom Li-on R2 TTL for Canon x 2 (Godox V860IIC, firmware v1.3)
  • Flashpoint XPLOR 600 TTL HSS (Godox AD600B, firmware v2.2, tried v2.3 as well)

When I tested the new 2.4GHz wireless TTL functionality with Canon 80D. All I get are overexposed images. It seems like all the flashes are always firing at full power. I've tried a bunch of setups to trigger the Zoom flashes as well as the XPLOR 600 with E-TTL:

  • on-camera R2 transmitter (overexposed)
  • on-camera Zoom flash as a wireless master (tried both ETTL mode and Group mode w/ ETTL, both overexposed)
  • single on-camera Zoom flash (works)
  • On camera Zoom flash using optical ETTL (works)
  • Wireless manual w/ R2 (works)
  • Wireless manual w/ Zoom as master (works)

At first I thought the problem was with the R2 transmitter or one of the flashes, but it seems odd that none of the wireless E-TTL combinations worked. From various sources on the Internet, I gathered that the problem might be specific to the 80D and the newer Canon cameras, as Canon like to mess with their E-TTL system whenever they release a new camera. I've personally confirmed that the wireless E-TTL system does work with the 70D. Has anyone using the Godox / Flashpoint E-TTL system with the 80D experienced similar problems?

p.s.

I have someone confirming that the wireless E-TTL + 5D Mark IV also overexposes the images initially, but the latest firmware (v18) for the R2 / X1T trigger seems to have addressed the issue. I've also updated to the v18 firmware on my R2 remote, I'm still seeing the overexposed problem on my 80D.

UPDATE: I've now updated the R2 remote trigger firmware to the X1T-C v19. This seems to have addressed the TTL overexposure problem when using the R2 remote to trigger the flashes. However, exposure compensation is still not working properly. Since the Zoom flash has no new firmware updates, using it as master still overexposes in TTL mode.

1

As of September 6th, 2017, all TTL functions are working as expected with the latest firmware updates. I've tested the TTL functionalities on both the 80D and the M5. You can download the latest firmwares here: http://www.godox.com/EN/Download.html.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.