2

I’ve got a problem that I don’t understand. I'd love to get a fix, but at least some advice.

Canon 7D2 with v1.1.0 firmware (latest). It’s always worked great. Sigma 150-600mm Sport with 1.05 firmware (latest). New from one of the big NY guys.

For the 1st time, I put the Sigma on my 7D2 yesterday and went out to test it. Very disappointing. My camera kept locking up. When the camera locked up, it could not be turned off. A spinning animation was displayed, with the message “Recording… Remaining images:1.” The only way out was to remove the battery for a few seconds. I gave up to go home and run some controlled tests.

Testing results… The camera/lens combination works great at 300mm and below. Works every time. The combination fails every time at 400mm and above. Very solid failure. I didn't test between 300-400 because I didn't think it would add anything to my understanding. When failing, no image gets written to the card. I waited almost an hour. I put on a Canon 100-400mm at 400mm at it works perfect. So, even though it makes no sense to me, my logic says the problem is the Sigma lens.

I think I can return the lens, but it was a closeout kit so I’m not positive. And… if I did, should I get a replacement lens or give up on Sigma.

I can try to contact Sigma and/or Canon, but haven’t spotted a good place to ask a question.

There is a Sigma authorized repair center about 60 miles from me. I guess I could drive over and hope someone would let me demonstrate the problem, and get their thoughts.

Advice (or better yet, a fix) ???

  • I'd try look for support from Sigma first -- if there's a general problem with that combination of lens and body, they're most likely to know about it. – Caleb Dec 3 '16 at 21:50
1

Try disabling "Lens aberration correction" in the camera's settings. That was the conclusion in this thread at canonrumors.com that covers what appears to be the same issue:

I just received the 150-600 and it works fine at lengths below 400. Above 400, I get distorted images and camera errors.


Also, on the 7D2, the image looks fine through the VF. It just locked up the camera. Then I looked through LV and saw the distortion. You can see the distortion "kick in" as you move past 400mm. I have tried with both AF and IS turned off and the result is the same.

According to that discussion thread,

The issue with third party lenses is that they send a lens identification code to a camera, and they must use a code for a Canon lens. Since there is no Canon 150-600mm lens, they use something close that works properly on the cameras they have available to test. Apparently, the new AF system on the 7D Mark II works differently and causes the problem.

  • Wow, scottbb, you sent me to the answer. Thanks! When I looked at the aberration correction settings, it did show the correct lens, so apparently Canon and Sigma have been talking but haven't quite got everything fixed. Of the three aberration correction settings, Peripher illumin. was disabled, Chromatic aberration and Distortion were enabled. I disabled everything and my problem was fixed! I may spend some time tomorrow figuring out which setting is the real bad guy, but for now I'm very happy. Thanks! – John Dec 3 '16 at 23:50
  • @John Glad you're up and running! I recently acquired the same lens for my D800E not too long ago, and it would break my heart if I couldn't use the long end, so I felt your pain a bit. If my answer worked for you, would mind marking it as the accepted answer? Thanks, and happy shooting! – scottbb Dec 4 '16 at 6:55
  • 1
    For someone in the future who might stumble across this discussion... After additional testing, the fix stands. Distortion needs to be disabled when using firmware as documented in the question. Also, I shoot raw to card 1, and JPG to card 2. I set card 2 to raw and it still failed. It seems to me that distortion correction should be a JPG only function. More testing could/should be done in this area. Canon/Sigma... a user, using provided settings... especially default, should not be able to lock up a camera to the point that it requires a battery-out reboot. – John Dec 4 '16 at 18:13
  • 1
    @John Even when set to save raw files, the camera still generates a jpeg preview based on the in-camera settings. If any lens correction is enabled it will be applied to the jpeg preview attached to the raw file. – Michael C Dec 4 '16 at 19:47
  • A bit more info for future folks that might have this problem. I contacted Canon, and, as expected, they said the problem was Sigma's. I contacted Sigma, and, as expected, they said the problem was Canon's. The Sigma tech told me that Canon makes the use of 3rd party lenses difficult. He pointed me to a statement in the 7D2 manual that says "When using a non-Canon lens, setting the corrections to [Disable] is recommended, even if [Correction data available] is displayed." – John Dec 5 '16 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.