1

I have a Canon 7D that I sometimes use for shooting video. I've been using a flat profile for a while and it works pretty well. I'd like to give the Cinestyle profile a try, but I can't seem to install it on my camera.

The website for Cinestyle says that it works with any "current" Canon EOS cameras, but doesn't specify which those are. They mention the 5D Mk 2 which is about the same age as my original 7D.

I've downloaded the Canon EOS Utility app v. 2.6, but it doesn't recognize my camera. Other photo apps on my computer do. I'm using macOS 10.11. When I run it, I get the "Connect an EOS Camera" message, but it never recognizes that my camera is connected and turned on.

Is my camera just too old to use with this app? If so, is there any other way to load the Cinestyle profile into my 7D?

  • What version firmware are you running on your 7D? – Michael C Nov 27 '16 at 3:01
  • Looks like version 2.0.0. – user1118321 Nov 27 '16 at 3:16
2

The 7D should work with EOS Utility v.2.xx.

I'm in a Windows 10 environment and my 7D running firmware v.2.0.3 communicates fine with EOS Utility v.2.14.20.0. (listed at Canon support as v.2.14.20a for Windows) which was released in December 2015.

The current EOS Utility version for Mac OS X El Capitan 10.11 showing on the 7D support page for Europe is v.2.14.20a for Mac. Have you tried updating to that version on your Mac? v.2.6 is ancient, having been released in early 2009 and may not be fully compatible with OS X 10.11.

If your 7D is running a newer version of the firmware (2.0.x with significant upgrades and changes was released in 2012) you probably require a newer version of EOS Utility even if OS X 10.11 can run v.2.6 from 2009.

From a press release regarding the 7D firmware version 2.0.5:

-Some older versions of the applications listed below do not support functions that are added by the new firmware. In order to address compatibility issues, please download the latest versions of the applications (listed below) from our Web site.

Since the CineStyle "Profile" is really just a custom Picture Style file (.pf2) any version of EOS Utility should be able to transport it from your Mac to your camera.

  • 1
    OK, so it turns out that the installer installs 2 different versions of the app. One ancient version that doesn't work, and a newer one. Unfortunately, it installs a shortcut for the ancient one in the dock and the new one is hidden inside a subfolder of a subfolder of the Applications folder. Once I figured that out and ran the right version it all worked fine and I was able to install. I wouldn't have thought to look, though, if it hadn't been for your prompting. – user1118321 Nov 27 '16 at 3:17
  • You can download the current version from Canon Europe here (USA page for 7D is currently not loading the software list. Don't you just love holiday weekends?): canon-europe.com/support/consumer_products/products/cameras/… – Michael C Nov 27 '16 at 3:20
  • Thanks for the link! Do you happen to have a link to get the latest firmware? – user1118321 Nov 27 '16 at 3:22
  • 1
    D'oh! Never mind - it's on the same page. – user1118321 Nov 27 '16 at 3:23
  • Or you can use the 5DII USA support page to download the same version of EOS Utility – Michael C Nov 27 '16 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.