0

I recently purchased a mint condition Panasonic Lumix FZ48, it takes pictures and for the first 20 minutes or so all the functions worked but then all the other buttons stopped working, I can't access the menu to reset the camera. I am unaware if the device is actually broken or if I have engaged a setting that only allows the shutter button to be used. Any help with this issue us is greatly appreciated, thank you.

1

Have you tried removing the battery for an extended period? Sometimes this will allow the camera to reset even if turning the camera off and back on will not.

  • That may have actually worked, to let the internal solid state memory's battery run dry, unfortunately i have returned the camera now but i accept that this probably would have worked. Thank you – J.Dolan Jan 1 '17 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.