2

Recently I've been getting the "Card cannot be accessed" error on my 2 months old Canon 1300D (Rebel T6).

The thing is, it only happens after I already snap a few photos, or after using the camera for a while.

Things I've done:

  • Checked the pins in the SD card reader, all seem fine (not bent)
  • Tried different SD cards (3 of them to be exact), all have the same issue
  • Blowing into the SD slot and cleaning the contacts on the SD card
  • Tried to open the camera and clean the SD slot but couldn't reach it (motherboard in the way)

Any other suggestions on else what I might try? Strange that it sometimes works, and sometimes doesn't.

I'm currently traveling, so leaving it to Canon for repair is not an option, since it will take 3-4 weeks. By that time I will already be in a different country.

Anybody had a similar issue?

  • 2
    Are the cards all the same brand and spec, and are they fully compatible with your camera? Cheap cards may not be what the manufacturers claim them to be. – Mick Nov 24 '16 at 12:59
  • Does this happen immediately after you snap several photos in a row, or even when the camera has been idle for a while (say, 15 seconds or more)? – Caleb Nov 26 '16 at 15:22
2

Found the problem!

It wasn't a problem with either the SD card brand or spec. Seems I had the camera exposed to a light rain, and some water might have damaged the SD card slot.

After opening the camera, cleaning up the SD card slot (the PCB and the pins) and letting it dry off for an hour or so, it seems that the issue disappeared.

Hope it helps someone having the same weird issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.