1

It's been a while since I used my Nikon D5200. Recently, I discovered tethered shooting with Lightroom and wanted to give it a try. I took out my dusty camera and tried to connect to My iMac running Mac OS Sierra. Unfortunately, the Mac is no longer detecting the camera. None of Image Capture, Photos App, Lightroom, Nikon CaptureNX or ViewNX are able to detect the camera. If I insert the SD card from the camera, everyone's happy, but I want to use the tethered shooting mode in Lightroom, or any of the other apps available. Help is appreciated.

PS:

  1. I'm using Lightroom 6.1 and D5200 is listed in the supported camera models
  2. The last time I was able to connect the camera was when I was running Mavericks (10.9)
  • Have you checked the Nikon website for updated drivers? Have you verified your camera is able to connect to any other computer or OS? – Carl Witthoft Nov 14 '16 at 12:40
  • I only have macs, all of them running Sierra. I've checked on all three. It's not detected anywhere. I have installed the latest Nikon firmware and lens data updates. Don't see any drivers for Mac on Nikon's website. – Code Poet Nov 14 '16 at 12:43
  • Next - pull the data card & connect directly to a mac, using whatever card-to-USB connector you have or buy. See if the card itself comes up. – Carl Witthoft Nov 14 '16 at 18:45
  • 1
    @CarlWitthoft From the OP as written: "If I insert the SD card from the camera, everyone's happy..." – Michael C Nov 14 '16 at 22:52
  • @MichaelClark That'll teach me to tl:dr things. Sorry – Carl Witthoft Nov 15 '16 at 12:23
0

In OS X, flash cards in cameras don't usually show up as disks. Instead, the camera presents itself as a USB Image Capture device. Apps that support the Image Capture Core framework (e.g. Lightroom, the built-in Image Capture app, etc.) can pull images from the device, delete photos from the device, and so on.

If that isn't happening, I don't see how it could be an outdated driver issue, as I think Apple provides those drivers themselves. (It could be a bug in Apple's driver stack somewhere, of course....)

Does the device show up properly when you go to "About this Mac" and choose "System Report"? If not, you probably have a bad cable.

| improve this answer | |
  • good point, I forgot to mention it. No, the camera doesn't show up in the System Report either. I will try changing the cable, didn't occur to me, because as such the cable has been rarely use. Worth a try though. – Code Poet Nov 16 '16 at 5:22
  • Either a bad cable or a bad connector. There's also a very small possibility that you might be encountering a device enumeration bug, but my money would be on a physical failure. – dgatwood Nov 16 '16 at 7:23
  • Feeling very silly, but yes, it was a cable problem. However, the tethered capture in Lightroom still won't work. – Code Poet Dec 27 '16 at 5:39
  • Tethered shooting involves a user-space driver that's part of Lightroom itself. Sounds like the Sierra update broke some incorrect expectation that Adobe had when they wrote their I/O Kit matching code. Try contacting Adobe directly, and make sure you're running the latest LR build. – dgatwood Dec 27 '16 at 16:23
  • Yes, I've found substantial evidence online that there have been problems reported with Nikon cameras on Sierra. Again, feeling silly about being so trigger happy and updating as soon as the update was released. Adobe says the problem is with Nikon SDK. They can't fix the problem until Nikon releases a patch. Sierra users should buy a standby Windows machine for the time being :) – Code Poet Dec 28 '16 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.