0

I'm new to photography and I've researhed about this over google and can't find the exact answer on this. I've read that the Digital Zoom option on Canon G1X should be enabled when you choose JPG as the file format for shooting but thats not the case on my end.

Ive already tried setting JPG as the format, and thats my default, but I still can't enable Digital Zoom from the settings menu. The only way I have access to it is when I set the mode dial to C2, which is Custom.

settings

lcd

Thank you

1

C2 is basically just a snapshot of the settings that were active in the camera when you chose to save that state as a "Custom" setting. If your camera won't do something in any of the other modes now that it will do in C2 it just means the applicable setting has been changed since the time the current C2 profile was recorded.

The basic menu option to enable or disable Digital Zoom is found by pressing the Menu button, navigating to the Shooting tab (the one with the camera symbol) and selecting Digital Zoom. You can then select from Standard or Off.

As outlined on pages 230-231 of the Powershot G1 X Camera User Guide, digital zoom is only available in certain shooting modes and not available in others. It is not available in the following shooting modes: SCN-High Speed Burst HQ, SCN-Handheld Night Scene, SCN-Stitch Assist, or any of the Image Effects (Creative Filters) modes.

There are other notes spread throughout the User Guide that describe certain features that are not available when other menu items are selected. A thorough reading of the User Guide after a problem is encountered is sometimes needed to find and isolated note that tells of the limitation.

One such note on page 56 says that digital zoom is only available when the 4:3 aspect ratio is selected. If any other aspect ratio is selected digital zoom is not available.

  • From page 51 of the Powershot G1 X Camera User Guide: "To deactivate digital zoom, press the menu button, choose [Digital Zoom] on the (camera symbol) tab, and then choose [Off]." gdlp01.c-wss.com/gds/5/0300006975/01/psg1x-cug-c-en-web.pdf – Michael C Nov 7 '16 at 3:55
  • Yes but that's my problem. It is not enabled or it can't be selected. It's there but it's not available to be selected. It can only be chosen under Custom. – Cisco1991 Nov 7 '16 at 4:05
  • solved it! I needed to switch to 4:3 size and it can now be selected in settings! – Cisco1991 Nov 17 '16 at 10:51
  • Yeah, it says so right on page 56 of your User Guide. – Michael C Nov 17 '16 at 14:48
  • Let's have the answer in an answer. Either Cisco you can add an answer or Michael update his to include the 4:3 aspect ration being required. – MikeW Nov 17 '16 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.