0

Some years ago, I bought a SDHC 8GB card for a Sanyo Xacti VPC-E6 camera and it worked fine. Then I used the card for other purposes. Now, that I'd like to use the card back in the camera, I cannot find the way to do it.

When I insert the card in the camera, it asks if I want to format or full format the card. With either option, the camera takes some questions but returns to the same question.

On Linux, I've tried to create a partition and format it with mkfs.vfat, which formats in 32 bit mode. No success. Tried to remove the partition and format the whole card, no success either. Changed the partition ID to various types, but it didn't work.

What should I do?

I have also another 1GB card formatted with one partition with FAT16 filesystem that works fine. But FAT16 doesn't seem to be the answer to this as the card is 8GB and worked fine when I bought it in first place.

  • Was your camera able to use/store/access the full 8 GiB when it used to work? That is, did you have more than 2 GiB of pictures on the card? – scottbb Sep 14 '16 at 15:08
3

You camera came out in 2005, maybe 2006? According to the user manual, you can use "SD Memory Card" and "Multi Media Card" (SD and MMC cards). Because of the age of the camera, and the lack of specificity about SDHC or certain SD card sizes, I'm willing to bet that you can't utilize the full capacity of even SDHC cards.

SDHC cards were introduced in 2006, enabling capacities over 2 GiB. I'm willing to bet your camera is not compatible with your card formatted as FAT32. Try FAT16. You just won't be able to use the full capacity of the card with your camera. But at 6 megapixels, that's probably 1000 high quality JPEG files before you reach even 2 GiB.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.