3

I have an EOS 750D and simple reversing ring. There is no problem with capturing photos using the viewfinder. I have to use M mode and set everything manually.

But when I use live view (or try to capture video) I can only see a black screen. When in video mode, there is a message: "Ensure the lens is mounted..." Then I can capture video, but it is only a black screen with sound.

Is there a simple way to fool the mount that there is lens attached, or do I have to buy a more sophisticated set? What pins of the EF mount shall be connected?

0
2

You may be underexposed in Manual mode and that's why exposure simulation is showing you a black screen. Try using Av mode, and seeing if exposure simulation now works to show you an image.

5

Basic cameras use "exposure simulation" in Liveview to help the shooter visualize what the final exposure will be. This creates problems when using manual lenses or any lens that does not communicate with the camera.

More advanced cameras have the option to turn off "exposure simulation" but basic cameras like the 750D or SL1 do not have this option and you must live with the dark screen.

One way to avoid this problem is to use a Canon compatible ETTL flash in the hotshoe as any Canon dedicated flash will automatically disable Exp Sim for flash photography.

One other option is to install Magic Lantern software on your camea as it includes an option to disable Exp Sim.

1
  • Wow I didn't know they didn't let you turn it off on certain models. Nice Canon. – dpollitt Sep 9 '16 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.