0

My Canon 70D gives Err01 when with a Tamron 90mm lens but works perfectly with other lenses. The same lens works fine on other bodies (1200D)

I'm not sure if a specific combination is giving an error.

I have tried to clean the contacts via lens cleaner liquid as well.

What can I do to get my lens working again?

  • Do you have the older Tamron 90mm macro (model F004) that has been around a few years or the newer one (model F017) introduced in early 2016? – Michael C Sep 9 '16 at 11:27
  • Its the older non-VC version (guess F004) – NitinSingh Sep 13 '16 at 5:57
  • Model F004 also had VC (The names are identical other than the model number). The newest non-VC version, SP 90mm F/2.8 Di 1:1 Macro (model 272), is even older. It was introduced in 2004. It replaced the SP AF 90 mm f/2.8 Macro 1:1 (model 172) which had superseded the SP AF 90 mm f/2.8 Macro 1:1 (model 72). – Michael C Sep 13 '16 at 7:18
1

A while ago my Tamron AF 70-300 4-5.6 Di SP VC USD showed the same error, when it was connected to my Canon 700D. When I removed it from the camera and attached it again, the error was gone for a while (sometimes minutes, sometimes days) and returned again. I sent it back to Tamron to have it checked and obviously there was something wrong with the lens' aperture.

According to Tamron's service Err01 is a very unspecific error and it's almost impossible to say, what is wrong with the lens without seeing it. Therefore I would suggest to talk to your Tamron distributor or send it back to Tamron so that they can check it.

1

Had to give my lens for service, they told that autofocus motor ring has to be replaced.. costed approx 70$.. they also replaced the lens barrel (new serial no now).. Lens now works smooth as new :)

0

If your Tamron 90mm Macro doesn't have VC, the newest version it could possibly be is the SP 90mm F/2.8 Di 1:1 Macro (model 272) introduced in 2004. There were also the model 172 and model 72 versions of the Tamron SP 90mm F/2.8 Di 1:1 Macro that preceded the model 272.

Part of the risk of buying third party lenses is that they are reverse engineered to be compatible with the camera models available at the time they are designed. Subsequently introduced camera models may or may not introduce additional protocols that were included but not used in the previous camera models. A third party lens introduced in 2004 is unlikely to be 100% compatible with a camera introduced in 2013.

Sometimes third party lens makers will update the firmware to make a lens compatible with newer camera models. But in the case of your lens that is a design well over a decade old. I doubt Tamron has devoted the resources to writing code that would make the model 272/172/72 versions compatible with current camera bodies. You might hope that there was an update made for your lens created to make it compatible with Canon bodies introduced in the mid-2000s. Perhaps it will also allow your lens to work with even later models.

I'd contact your regional Tamron service representative and see what, if any, updates are available for your lens. You'll need to examine your lens for exact name and model markings, serial number, etc. and have that information available when talking to a Tamron representative.

  • I have the 272E version, without the aperture ring. As for the bodies, 1200D(T5) and 70D are almost the same time bodies, so shouldn't be any difference – NitinSingh Sep 16 '16 at 3:36
  • Has it worked in the past with your 70D? Or only with the 1200D? – Michael C Sep 16 '16 at 3:42
  • The 1200D has a DiG!C 4 processor. The 70D has a DiG!C 5+ processor. Even though they were introduced at the same time the comparison can be like two computers from Dell: One has an Intel processor and the other has an AMD cpu. Some instruction sets are completely different with different processors. – Michael C Sep 16 '16 at 3:47
  • It used to work initially with 70D, but then I have mostly mounted my other telephoto on it, and 90mm got on my 1200D... Now 70D refuses to take 90mm. As for the 4/5+ an increase in processor level shouldn't really mean stopping old lens.. Maybe not perform accurate, but atleast should work – NitinSingh Sep 18 '16 at 17:25
  • The difference between a DiG!C 4 and DiG!C 5+ may be far more than just a "level". They could have radically different architectures and instruction sets. The difference between a DiG!C 5 and a DiG!C 5+ would be more of an incremental change. – Michael C Sep 19 '16 at 0:35
-1

So if your Tamaron 90mm macro lens is a manual lens, then there is this manual "aperture ring" on the end of the lens , near the camera body attachment. Twist it all the way to the smallest aperture marked. Probably 22 or 32 I guess. and lock it into position. things will be fine.

Tamaorn 90mm lens which shows the aperture ring

  • The Canon version of that lens did not have an aperture ring, since all Canon EF lenses have electronic aperture control and the cameras (thankfully) have no mechanical aperture control linkage to get bent or out of adjustment. The lens pictured in your answer is probably for Nikon. It certainly isn't for the OP's Canon. – Michael C Sep 16 '16 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.