1

Suddenly my camera says "Card cannot be accessed. Reinsert/change the card or format card with camera". I have canon EOS 600D. Help me

  • 7
    Have you tried reinserting and/or changing or formatting the card? – Michael C Aug 5 '16 at 6:08
  • i tried new 5 card but same problem. also try to find the solution on internet but found same problem of many people but didnt find the solution. i change card and format on other camera but it didnt work. again i face the same problem. – kamal subedi Aug 5 '16 at 9:18
  • 2
    You could have damaged the slot - it is not impossible. Try looking inside and counting the contacts. – Euri Pinhollow Aug 5 '16 at 12:20
  • SD slots are really pretty tough. It seems more likely that there's gunk stuck to one the contacts. I'd try pressurized air just in case. But before I did that, I'd try removing and reinstalling the battery in case the camera is just in some weird semi-crashed state. – dgatwood Oct 1 '16 at 1:44
1

We had this happen to our 6D and it was the circuit board. Sent to Canon for repair and $400 - $600 later it came back working. I believe on this occasion they should have ate the cost, but it wasn't my camera and I didn't handle the return.

Here are some things we checked before sending in for repair:

Check that the card is formatted properly (WARNING!)

  • Check that the card is formatted properly for your camera. Some cards come formatted differently (FAT32, exFAT, etc). Generally I would use a computer to check the card for anything i needed first then format in the camera using the low level format option. Don't format your stuff dude, that would suck.

Check that the card isn't damaged or in locked mode

  • I understand locked mode shouldn't do anything, but why not check. Also, if you wrote on the card with a pen, or it is damaged then it might be the card.

Check another card

  • Plop in another card that is compatible with your camera.

Make sure the card is compatible with your camera

  • Cameras and cards are not all created equal. Some cameras can not use cards if they are 'too good' for your camera, and some cameras can not read or see cards that are 'too basic' for your camera bus.

Check that you are using a Canon battery

  • I know this sounds strange, but I recall we had problems with non-Canon batteries (el cheapo) and card read errors. Not sure why.

Power down the camera, pull the battery

  • Power down the camera, pull the battery and wait a minute then reinsert

Check the card contacts and clean them

  • The contacts can have bad contact with the camera contacts for a number of reasons. Clean the contacts properly and try again. Also, check the camera contacts in the slot using a flashlight to ensure there isn't anything like fuzz stuck in the port or damaged pins.

Call Canon Tech Support, Send for Repair

  • Although there might be more things to check, at this point we thought it was time to get the manufacturer involved. So we called, then sent it in. Now it works.

Hope you get good luck and it is simple. Last note. Check the video record after you think it is fixed. Even after we got ours working temporarily we noticed it would have a write error in a short amount of time while recording video.

0

If trying other cards has not worked (as indicated in comments), then the problem is not the card, it's the camera. You will need to get it repaired or at very least disassembled and cleaned by a specialist.

0

It might be the card, it might be the camera. Check for dirty contacts on both. If that doesn't help, try the card in a card reader attached to a computer, try a different card in the camera. Now you know where the problem lies, yes? If it's the card (and the pictures on it matter) there is free software that MIGHT be able to retrieve them.

protected by mattdm Aug 4 '18 at 9:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.