0

I am a beginner photographer with a Canon 7d and MacBook Pro. I'm not sure if Adobe camera Raw is compatible with either and really need advice on how to go about downloading the correct version.

  • I can guarantee that CS5 will work with the 7D, as well anything newer. Can't comment on older versions. – Robin Jul 7 '16 at 20:33
  • Please see this answer to a slightly different question: photo.stackexchange.com/a/45283/15871 – Michael C Jul 8 '16 at 0:45
1

Here is Adobes camera requirements for ACR (which program version starts supoorting the camera model):

http://helpx.adobe.com/camera-raw/kb/camera-raw-plug-supported-cameras.html

7d should be no issue for anything remotely modern.

A new camera model just out today may have to wait a few months.

Regarding modern, here is Abobes Program version requirements (program version compatible with ACR version):

http://helpx.adobe.com/camera-raw/kb/camera-raw-compatible-applications.html

0

ACR will process CR2 RAW files from the 7D without issue. If you have the most recent versions of Photoshop/Lightroom, then you'll not have a problem. (In fact you'll be fine with CS6, possibly CS5)

Personally, I always found Apple's own Raw converter (Digital Camera Raw - built in at a system level) handled Canon RAW files better than ACR, but if you're a photoshop/Lightroom person, that's not an option. If you use Photos (or the sadly defunct Aperture) then you can process there, and round trip to Photoshop if need be.

0

As Adobe updates ACR to support newer cameras, compatibility with the newer versions of ACR also requires newer versions of Photoshop. What version of Adobe Camera RAW you need depends on exactly which camera made the raw files in question and which version of Photoshop you are using. Once you know what the earliest version of ACR is that supports your particular camera, then you can find the earliest version of Photoshop that supports that version of ACR. For newer versions of Photoshop you may also need a newer version of ACR than the oldest one that supports your camera.

Here is a link with a comprehensive set of instructions from Adobe that addresses the issue you are encountering.

http://helpx.adobe.com/x-productkb/multi/troubleshoot-camera-raw-photoshop-photoshop.html

Here is a link that lists camera models currently supported by Adobe products via Adobe Camera Raw and the earliest version of ACR that supports raw files from each camera. The chart also lists the earliest version of Adobe Lightroom that supports raw files from each camera (via the listed version of ACR).

From the chart linked above we see that the earliest version of ACR that supports the Canon EOS 7D is v5.6. ACR v5.6 requires either Lightroom v2.6 or later, or Photoshop CS4 or later which would include all versions of Photoshop CC (please see this link). Note: The above information is for the original Canon EOS 7D. If you have a Canon EOS 7D Mark II the earliest version of ACR you can use is v.8.7 which requires Lightroom 5.7 or later, Photoshop CS6 or later, or Photoshop CC or later.

If you choose to use Adobe DNG Convertor to convert your raw files to a DNG version supported by an older version of Photoshop, be aware that the conversion may remove some of the functionality and flexibility you would have if you used a newer version of ACR/LR/PS to work with the raw files directly. This will probably be most noticeable with regard to color and noise profiles for newer cameras used with older versions of ACR/LR/PS. Again, it all depends on which camera (and more generally, which manufacturer) the raw files are coming from.

0

The Adobe website has all the information you need. Adobe, being closely tied to Apple historically, means that their software nearly always runs on Macs, and sometimes Mac versions of Adobe software are released before the Windows version (e.g., Lightroom).

What you need to know are two version numbers: the version of the ACR plugin that supports your camera model's RAW files, and the first version of the software application (Lightroom, Photoshop, Photoshop Elements, etc.) that supports that ACR plugin version. You typically won't run into issues with older camera models if your software is up to date. You more often run into an issue if you haven't upgraded your software to stay current and you purchase a camera model soon after it's first released (aka "The Photoshop Tax" on new cameras).

If you use Lightroom, the Adobe webpage that lists Cameras supported by Camera Raw will tell you both of those numbers for your specific camera model. In this case, the Canon 7D requires ACR v5.6 (or later), and Lightroom v2.6 or later.

ACR 5.6 came out in 2009. The ACR 5.6 page on the Adobe website that it is compatible with says:

Camera Raw 5.6 update

This new version of the Camera Raw plug-in replaces the original Camera Raw plug-in that was installed with Adobe® Creative Suite® 4, Adobe Photoshop® CS4, Adobe Photoshop Elements 8 and Premiere® Elements 8 software.

If your processing application version is earlier than this, you won't be able to use ACR v5.6, and will need to upgrade in order to get a version of ACR that works with the 7D's RAW files.

If you can't do that, then you could consider using the current version of Adobe's DNG converter to convert your RAW file to DNG format that your software can handle. (See also: DNG converter doesn't convert, Photoshop CS2 doesn't open DNG).

Getting the plugin

Getting and installing the latest ACR plugin usually involves just upgrading the plugin from within Photoshop (Help → Updates). If your version is too old to have this feature, you can also download the plugin and find the installation instructions on the Adobe website for the specific ACR version you want (in this case, the page for v5.6).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.