1

I recently went flying with a friend and took my Nikon D3300 DSLR up with me to get some aerial shots. As I'm still learning I set the camera to RAW+JPEG so I had some pics and could also have a mess about with the RAW process to learn some new skills. I have UFRaw to open the .NEF and TheGimp 2.8 to edit them. I opened the RAW files and they open in black and white, yet the JPEG ones are in colour and when I tried the RAW Processing feature on the camera itself the pictures are in colour also, its only when I open them to edit them that they come out in b&w. Any help would be greatly appreciated as I am completely stumped as to why its happening. Thanks in advance! :)

  • 1
    What version of ufraw? Can you try Darktable and Rawtherapee as well? – mattdm May 6 '16 at 11:51
  • I'm using UFRaw version 0.19.2, I haven't tried the other 2 that you mentioned but I will certainly give them a try and come back with my findings. Thanks – Blizz23 May 7 '16 at 14:20
2

Raw editors usually ignore the in-camera settings for things such as color and contrast. Instead they apply the user selected profile from the application you use to open the raw file and convert the raw data to a viewable image on your screen. It sounds like you (or someone else) have selected a B&W profile to be the default way your application opens raw files. You need to change that default profile to one that renders your images in color.

  • Thanks for your reply Michael, although sadly I have no idea how to change the default profile, I have had a look but cant find anything to instruct me how. – Blizz23 May 7 '16 at 15:37
1

I have no experience with the software tools you mentioned, but googled up a discussion thread on the UFRAW sourceforge site, where folks mention having an issue with RAW opening in B&W, and rbellavance posted a list of things to try that I paraphrase:

  1. Go to the Grayscale tab.

  2. Check that None is selected for Grayscale mode.

  3. Go to the Corrections tab.

  4. Check that the Saturation slider is not 0 (or near-zero); 1.00 should be normal.

  5. As a last resort, quit UFRaw and remove the .ufrawrc file from your home directory.

  • Thanks for your reply inkista and taking the time to have a look. I have tried the instructions you found all that changes when carried out is the image goes red, I have followed the instructions each step and thats the outcome. I have since tried Rawtherapee, as suggested by mattdm and that opens the file in colour no problems at all. Now I just need to learn how to use that programme! Again thank you very much for your helpful reply! :) – Blizz23 May 8 '16 at 13:04
  • @Blizz23. You're welcome! Since this is SE it's more helpful to upvote/accept in lieu of thanking someone in a comment (comments are more like footnotes). Read the tour, if you plan to stick around. – inkista May 8 '16 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.