4

I use darktable for my digital workflow.

The datetime in some of my images is off by a couple of hours.

I changed the datetime in all the relevant tags I could find in the *.NEF using exiv2:

  • Exif.Image.DateTime
  • Exif.Photo.DateTimeOriginal
  • Exif.Image.DateTimeOriginal

Nevertheless, the image information in the lighttable view of darktable still shows the original (wrong) datetime.

Does anybody know where darktable is getting datetime information from?

Your input is appreciated.

1
  • A note on the usage of the various DateTime tags, according to MWG Guidelines. Exif.Photo.DateTimeOriginal - when a photo was taken Exif.Photo.DateTimeDigitized - when an image was digitized Exif.Image.DateTime - when a file was modified by the user
    – asp
    May 1 '16 at 19:08
6

Because darktable stores this info in its own database on initial import, you will have to force it to re-read the info from the altered files. The sure-fire way to do this is to remove the files within darktable and re-import them.

In the case where you have image edits that you don't want to lose, you'll need to create .xmp sidecar files for the image files (if you don't have this enabled by default in settings), then remove the images from within darktable, perform the datetime change on the .xmp files, then re-import the files into darktable. You can find discussions about various specific cases related to this on the mailing list (example).

Also note that you can offset the datetime info for the image directly in darktable's database using the time offset function of the geotagging module, rather than editing your RAW files (some people claim that you shouldn't perform exif edits on RAW files, I can't speak to that).

2
  • 1
    Since all my images have been off with the same amount of hours due to frequent change of timezones, the advice on the geotagging module is simply great!
    – twan163
    Apr 30 '16 at 13:11
  • Yeah, the time offset feature can be a little bit hard to discover if you're not actually geotagging, unfortunately... Apr 30 '16 at 21:38
0

This is because DT relies on DateTimeOriginal which, for us poor Nikon users, is not modified by exiv2 - despites what it displays. So, until exiv2 team decides to fix this, we will have to suffer this behaviour.

0

On Darktable 3, editing the DateTimeOriginal field in the XMP sidecar file using a text editor, then restarting Darktable, will result in a prompt asking whether you'd like the Darktable DB to be updated to match the XMP file, or the XMP to be updated. For anything greater than 24 hours this works where the GeoTagging approach won't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.