2

I had my Canon 5D MkII set up and working with the Magic Lantern firmware (ML) for some time without issue. Unfortunately, I handed the camera to someone without remembering to mention the following note from their website:

Important notes

  • After opening the card door, always wait for LED confirmation (or for 5 seconds) before removing the card, even if your camera is turned off!!!
  • On this camera, removing the card too fast might cause permanent damage.

Needless to say they removed the card too fast and the camera now has issues, specifically of the four CF cards I use with it, only one now works.

Card                         Result
4GB  Calumet Prospec 305x    Err 80
8GB  Calumet Prospec 305x    Works fine
16GB SanDisc Extreme IV      Err 80
64GB Calumet Prospec 505x    Err 80

CF Cards

I've tried installing/uninstalling ML from the one working 8GB card and everything works as expected. If I insert one of the other three cards, it will usually give Err 80 on the LCD, or nothing will happen. After this I need to pull the battery out for a moment to get it back to working with the 8GB card.

I've tried formatting the cards that don't work on a Win PC to see if that helps, but the behaviour is unchanged. When inserted into a Canon 20D all cards work except the 64GB one (I imagine due to it's size and the cameras age). Formatting the cards in the 20D then inserting to the 5DmkII also produces no change in 5DmkII behaviour.

Anyone have any ideas for further investigation into this or if a fix of some kind is possible?

  • 2
    Do the bad cards work fine in another camera? – Mike Sowsun Apr 23 '16 at 1:12
  • @MikeSowsun, Indeed, they all work as expected in a 20D (except 64GB). I tried formatting in the 20D to see if that helped, but no effect :/ – a_henderson Apr 23 '16 at 10:39
  • 1
    Have you tried updating/reinstalling the firmware for your 5DII? – Michael C Apr 23 '16 at 17:18
  • Do you have ML re-installed on the three non-working cards? Is the MAGIC.CFG file identical across all the cards? – inkista Apr 23 '16 at 17:38
  • hey when you say "or nothing happens" does that mean the camera acts as if it was "off" or the battery were dead? – trying_hal9000 Sep 29 '16 at 3:51
4

About the only thing you have not tried that might help is to update/reinstall the firmware for your 5D Mark II. The last version listed at Canon USA's support page for the 5D Mark II is version 2.1.2

There are instructions that become visible when you click the "select" box for the listing of version 2.1.2. They tell you how to download the zip file, extract the files contained in the zip file, and where to find the .pdf with installation instructions included in the contents of the zip file.

If that doesn't work then your only other options are to either deal with it by only using the one card that works or by sending the camera to a Canon authorised service center to see if they can reflash the camera's boot files.

You're actually very fortunate that the camera wasn't totally bricked by pulling the card out while the camera was trying to read or write to the card.

  • 1
    The camera was on firmware 2.1.2 but I tried reinstalling that to see if it would help as you suggested (using the one working 8GB card). To my absolute delight that has caused the camera to return to full functionality! Indeed very lucky it wasn't bricked, thanks muchly for the suggestion :D – a_henderson Apr 24 '16 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.