I'm trying out tethering for... not quite the first time, but the first time I'm taking it relatively seriously, and I'm noticing something that was not quite to my expectations:

When I shoot in the tethering mode that's built into Aperture 3 (currently at 3.1.1) with my Canon 30D (Firmware version 1.0.6), the images are capturing (either when triggered from the camera, or from the computer) just fine, and being transferred just fine to the computer, but they're not being stored to the card.

Is there some way I can get them to also be stored to the card? I have some workflow around importing from the card that I'd like to still be able to use after a tethered shooting session... but I can't do it if it's not on the card.

Now, granted, the images are on my computer... it's just that they're stored with different image numbers, and other little things that maybe don't "really matter", but they matter to the particular way I do my workflow (lots of automation around things, very customized).

Is this possible? What settings can I change, either on the camera or in Aperture?

Or perhaps there's an alternate piece of software that I can use (Canon's native software? I haven't tried running it in forever, would it run in MacOS 10.6.6?) to do the tethered shooting, even if that means taking Aperture out of the picture until the later import?

Any help would be appreciated. Thanks!

  • 1
    \$\begingroup\$ Not sure if it's possible, I found a Flickr thread that doesn't sound too promising: flickr.com/groups/aperture_users/discuss/72157625375107442 \$\endgroup\$
    – ahockley
    Jan 24, 2011 at 16:05
  • \$\begingroup\$ @ahockley: bummer... thanks. Based on that, I've submitted feedback to Apple... hopefully they'll fix this for the next point release. \$\endgroup\$
    – lindes
    Jan 24, 2011 at 17:38

1 Answer 1


I don't know of a way to do it with Aperture, but you might try playing around with Automator. It has a "Take Picture" action:

alt text

This has an option to Delete picture from camera after downloading, which you would want to disable.

I don't think you can avoid downloading the recently taken image with Automator, but at least you can leave it on the card.

Another option is to use gphoto2, which is a library/command-line tool that allows for controlling a camera over USB. Just install gphoto2 (macports has a port for it which makes installation easy), and run gphoto2 --capture-image to take a picture without downloading.

  • \$\begingroup\$ Oooh, gphoto2 looks interesting indeed! macports is installing it now... I'll check it out, and report back. I'd still ideally like to be able to do this within Aperture (and so, not "accepting" this answer, at least not yet -- but it definitely gets an up-vote), but I might very well be able to work with this. Thanks! \$\endgroup\$
    – lindes
    Jan 24, 2011 at 16:39
  • \$\begingroup\$ Hmm. Something is preventing either of these from working, it seems. When I connect my camera, it flashes "busy", whether or not Aperture is running. If I launch aperture and do a "start session", all works fine as before, and gphoto2 --auto-detect sees my camera, but if I try to capture an image, it reports "Could not claim the USB device"... which is in the faq -- gphoto.org/doc/manual/FAQ.html#FAQ-could-not-claim-USB -- but no real mac-specific info, and I'm not sure what's using the port. I suspected Finder (Mass Storage...), but I don't see the camera there. :-/ Any hints? \$\endgroup\$
    – lindes
    Jan 24, 2011 at 17:12
  • \$\begingroup\$ oh, and Automator sees my camera, and claims its status is "Ready", but if I run the workflow, it just blocks until the camera turns itself off, and then it says it "completed". Sigh. Oh, and if I re-launch aperture (or have it launched when I plug in or turn on the camera), it automatically sets up the "Import" dialog, even though I have "When a camera is connected" set to "No application" (it doesn't launch Aperture, but when Aperture is running, it launches the import mode) \$\endgroup\$
    – lindes
    Jan 24, 2011 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.