1
\$\begingroup\$

I have a Canon 70D, YN-560-TX and two YN-560IV flashes. The YN-560-TX is synced to the flashes and they work when I press the test button on the transmitter, but when I try to fire with the transmitter on camera it doesn't seem to want to fire. I've tried resetting, changing channels, cleaning my hotshoe but nothing seems to work. Please help!

\$\endgroup\$
1
  • \$\begingroup\$ Are you using Liveview? (3rd party non ETTL flash units are disabled in Liveview) You should be able to disable "silent mode" in Liveview to fix the problem. \$\endgroup\$ Mar 6, 2016 at 12:34

1 Answer 1

1
\$\begingroup\$

I suspect you are using Liview. In Liveveiw flash sync is disabled if "silent mode 1 or 2" is enabled.

Using a Canon flash will automatically disable "silent mode" but some 3rd party flash units or triggers are not recognized. Go into the Liveview menu to disable it.

Rebel series cameras have no option to disable "silent mode" so it difficult to use a 3rd party nonETTL flash unit or trigger.

enter image description here

enter image description here

\$\endgroup\$
3
  • \$\begingroup\$ Some third party flashes or triggers are not recognized. Some (a lot) of them made specifically for Canon cameras manage to fool the camera into thinking they are a genuine Canon model. \$\endgroup\$
    – Michael C
    Mar 6, 2016 at 15:44
  • \$\begingroup\$ Thanks, I edited my answer to say "some 3rd party flash units or triggers are not recognized". I believe most 3rd party ETTL flash units are recognized while the non-ETTL manual units are not. \$\endgroup\$ Mar 6, 2016 at 16:02
  • \$\begingroup\$ Yep. The non-E-TTL manual units aren't usually made in separate Canon or Nikon varieties. \$\endgroup\$
    – Michael C
    Mar 6, 2016 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.