1

I bought a Yongnuo RF-605C and Yongnuo YN-560-TX and I can't work with them. I think that there is no connection between them. The flash works properly when I use the triggers off of the camera (Canon 550D) but when I put the trigger on the camera they don't work.

What can I do?

  • What do you mean by "don't work"? That the flash doesn't fire? Or that something else doesn't work the way you expect? – inkista Jan 31 '16 at 19:38
  • So manual triggering the flash with the remote works, but if you put the remote on the camera hot shoe, it does not work? What Flash mode are you in and what is the flash set to in the menu? – TFuto Feb 2 '16 at 19:01
1

Have you followed the instructions in the manual for troubleshooting?

Which camera do you have? Are you using Liveview on your camera? Many 3rd party flash or triggers will not work with Canon Liveview.

Higher end cameras like the 60D, 70D, 5D, 7D etc all have an option in the camera menu to disable "Silent Shooting" while in Liveview. This allows the trigger or flash to work while in Liveview.

The 550D and other "Rebel" series cameras do not have this option and there is no easy way to make your flash or trigger work while using Liveview. You must then use the optical viewfinder.

enter image description here

  • The 550D is in the tags, so I updated that as the camera body in the question, as well as adding in the info from the comments. OP mentions firing works ok with the transmitter off-camera, so probably not a channel/mode/group issue. But restoring factory settings never a bad idea. – inkista Jan 31 '16 at 19:41
  • Thank You, Thank You, Canon 60D Taken out of Live View, Now Works like a Charm, (2) Canon Speedlights with (1) Yongnuo YN560-TX Flash Controller,(2) Yongnuo YN622C II Flash Triggers, – J. Stravage Oct 10 '18 at 17:22
1

Check that the transmitter is seated properly (pushed all the way in) on the camera hotshoe. If the pins and contacts on the foot of the transmitter are misaligned, then the commands can't be communicated.

Also, in the camera's menu for flash, disable Wireless. That function is for Canon's optical wireless system.

see also: The Other YN622C User Guide, particularly the "Getting Started" section.

  • Thank you so much about your help. When i use the triggers without the camera everything it's ok, but when i put one trigger in my camera's hotshoe then the trigger's light is red and it is out of order. Do i have any problem with me hotshoe? I ordered triggers for canon. – apo green Jan 31 '16 at 20:27
  • @apogreen Are you using the TX unit on the camera hotshoe, or another 622C? Are you sure you're not mounting the transmitter unit backwards? Are you sure the camera's hotshoe is clean (i.e., maybe use a blower) and unblocked? – inkista Jan 31 '16 at 20:56
  • I tried everything, the triggers work properly. The problem starts when i put the triger on the hotshoe. i suppose there is a problem with the connection. I can't do something more. I am waiting an asnwer from trigger's seller. – apo green Jan 31 '16 at 21:26
0

Are you sure the YN560-TX is compatible with your camera? I just bought one for my Canon 5D Mark II and I had the exact same problem. Turns out they sent me one that was not for Canon. I had them send me another one and the box had a "C" in red on it and it worked great. So maybe you are having the same problem I had. Just something to consider.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.