3

I am trying to download photos from a Canon 6D onto my computer and the EOS utility does not recognize the camera (only the monitor folder is available) I've tried everything:

  • Downloaded the program twice
  • Wi-fi is disabled
  • The battery is full

The only thing I can think is that the cable is damaged (while connecting to the computer any lights turn on the camera?)

Do you have any other idea that can help?

  • Have you tried a different USB port? Especially one that is on a different USB connection to the motherboard? – Michael C Jan 13 '16 at 18:02
3

Do you have any other idea that can help?

The easiest method is to take the SD card out of the camera and stick it in the SD slot in your computer, or if you don't have a computer equipped with such a slot, into the SD slot of a memory card reader. Cheap readers cost as little as $5; better ones read faster, work with more kinds of cards, and cost maybe $20.

Another option is to transfer the images via the 6D's built-in WiFi. If you've never done this before you'll probably have to spend a few minutes with the manual to get things configured right, but after that the only drawbacks are that it uses (relatively) a lot of battery power and isn't nearly as fast as reading the images straight from the card.

the only thing i can think about is that the cable is damaged (while connecting to the computer any lights turn on the camera?)

Whether connecting via USB or WiFi, the camera will need to be switched on in order to be recognized, so the back display may be active. Also, there's a red "access lamp" on the back of the camera that lights when reading the memory card, and you'll see that light up as you start to read images from the camera.

1

In addition to Caleb's answer, maybe your problem is neither the camera, nor the wire. Maybe the problem is your PC and/or USB port. So please try connecting your 6D with another PC. Also you can try to put the SD card in another PC.

0

My Canon 6d has the same issue. I have 3 usb ports on my new laptop. All three recognize my wireless mouse, so the usb ports are good. My camera connects fine to another computer. For some reason, if I connect my camera to one of the usb ports, then restart the computer, it recognizes the camera. The other 2 ports still won't work. My wife suggested that since some of the computers at her work have the same issue. I am running 64 bit Win10 on a new laptop. My other computer is running 32 bit win10. Not sure if there is an issue with WIN10 at 64 bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.