I've just signed up in the hope someone can help with my issue.

I must have bought a couple of dodgy SD cards once, since one of them started to break apart (inside my second SD slot).

Anyway, I noticed that the card would no longer push to eject. I had to manually grab it and pull it out. After disposing of this card, I could see small pieces of plastic inside the slot near the pins. I managed to get them out (I think, never did find the debris) with long tweezers. So now the push to eject works properly.

The new problem I'm now having, and to be honest it could have been happening for years but I've never run the camera with only one card before is this:

I remove the card from slot 2, and the slot doesn't recognize I've taken the card out, and keeps on throwing "card" "Err" messages if I try and take a picture without the card. Most of the time, I can put the card back in and it will carry on working. I can see that if I get 2 cards in again, it will become transparent, but I would really like to fix it.

I've updated to the latest firmware with no luck, and I cannot see anything in the slot that looks like it could be tricking the camera. Is there a sensor in there that I may have damaged and this is giving the false reading?

Update: I have been in contact with Nikon, who had me go through all the usual troubleshooting. Anyway, still not working. They have given me an indication of parts and labour for a new SD module, and that is approx GBP 160.00.

I'll have to have a think on that, especially since I have a workaround of sorts.

Update: Contacted Nikon, who wanted the best part of GBP200 to replace the card reader.

Sold it on eBay to a camera shop in the end. Just not economical to repair to be honest.

  • Thanks Mike, sorry I wasn't sure where to put that info...and until I got a reply yesterday I'd totally forgotten I'd asked this question here.
    – Slamdog
    Jan 10, 2017 at 13:19

3 Answers 3


Is there a sensor in there that I may have damaged and this is giving the false reading?

There is a contact switch in the SD card socket that detects the presence of a seated card. This switch is part of the SD card socket assembly. It is possible that some of the debris plastic has become lodged behind the switch, preventing the switch from moving when a SD card is inserted. You could use a can of compressed air to try to blow out any dust or plastic particles that may still be there.

This discussion at photo.net covers a similar "Card Err" problem with the D7000. Most of the responses also suggested using the canned air. Additionally, one of the responses seemed to indicate that multiple insertion/removal of a SD Card into the affected socket eventually "fixed" the problem.

  • Thanks Scott, tried it at work today but no luck on the air.
    – Slamdog
    Jan 12, 2016 at 22:29

All I know is that Nikons seem to be very sensitive when it comes to memory cards.My D810 won't accept anything other than an at least a "6" rated full size SD card. It won't accept micro sd's in a converter no matter what!


It is suggested that you try to clean your SD card slot once again by blowing out the SD card slot with an air duster to remove any traces of particles in it.

  • Yes, because I wouldn't have tried this (in the intervening 12 months). With a blower and with a can of compressed air.
    – Slamdog
    Jan 9, 2017 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.