Canon use only 4 digits in the filename (eg: IMG_1234.jpg)

My camera has wrapped around the file numbering so that I now have 2 photos on the memory card with the same name. Picasa fails to import the newer photos with names that already exist on the card. I tried browsing the camera via USB with Windows XP and only one file is shown for the given filename (unsurprisingly). When I copy it onto the machine it is the older photo.

I don't want to delete any files from the card as it is a handy backup for me since I am 4 months into 12 months of travelling.

I don't have EOS Utility installed and can't find it on Canon's website. Nor do I have a CF card reader.

Any suggestions for how I can get my latest photos off my camera and onto my laptop?

Thanks, Matt

  • 1
    \$\begingroup\$ Next time or if you see one, buy card reader. They are really cheap (under $10 for single-format), much faster and don't use the camera's batteries. They also avoid these sorts of problems because you card shows up as a normal drive in all cases. \$\endgroup\$
    – Itai
    Jan 19, 2011 at 16:27
  • \$\begingroup\$ Would it help to delete the file that you've already managed to retrieve from the camera, using the camera's own browsing interface to delete the image? \$\endgroup\$ Jan 19, 2011 at 23:51
  • \$\begingroup\$ @Itai yeah, I think I will. I've always been a bit reluctant to pop that card in and out so much, but I guess it's designed for it! \$\endgroup\$
    – matt burns
    Jan 23, 2011 at 12:21
  • \$\begingroup\$ @drfrogsplat I tried that but it still didn't work. It would not really solve my problem anyway as deleting the old files is exactly what I wanted to avoid. \$\endgroup\$
    – matt burns
    Jan 23, 2011 at 12:22

3 Answers 3


I can confirm that the EOS utility does import the duplicate files without any problems (and, as a side point, faster than Picasa too).

For some reason the EOS utility is not on Canon's website and my CD is a few thousand miles away.

Luckily I've found a workaround:

  1. Download EOS Utility updater from Canon's website
  2. Edit your registry (see below) to trick the updater into thinking you have already installed a version
  3. Run the updater.

I added the following registry entries for my system:


For more info, see the site that helped me

If anyone has more info on the cause of my original problem or other solutions, I'd love to hear them.

Thanks, Matt

  • \$\begingroup\$ It never stops to amaze me what people succeed doing while hacking their system. It is amusing to think that companies are still trying to protect and hide their system internals from hackers... \$\endgroup\$
    – ysap
    Jan 19, 2011 at 18:05
  • \$\begingroup\$ I agree, it's crazy. The trouble is in trying to protect themselves, they annoy their real customers (me) at the same time. \$\endgroup\$
    – matt burns
    Jan 23, 2011 at 12:19

Most cameras increment the folder number when the photo number wraps round. I'm sure the 7D does this. The FAT32 filesystem used by the camera doesn't support multiple files with the same name unless they are in different folders.

XP is fully compatible with FAT32 so if you plug the card in directly and it's on the card then you should be able to see it in Windows. Unfortunately Canon haven't made it so the camera acts like a USB mass storage device (like other manufacturers do) so you need a card reader to actually have full access to your photos!

  • \$\begingroup\$ It is actually not that simple. It happens that under Win XP, plugging in the 7D does not provide you with a virtual drive letter to browse the files while connected to the camera. You need to use either EOS Utility or a card reader. \$\endgroup\$
    – ysap
    Jan 19, 2011 at 18:02
  • \$\begingroup\$ I was assuming he was using a card reader actually as the windows interface doesn't even let you copy raw files! \$\endgroup\$
    – Matt Grum
    Jan 19, 2011 at 18:41
  • \$\begingroup\$ @ysap, True, it doesn't load as a USB mass storage device, but it does come up as a "digital camera" in windows under My Computer so you can see some files (just my problem subset), but not the true file structure. \$\endgroup\$
    – matt burns
    Jan 23, 2011 at 12:24

Take the card out and put it in an sd reader. You can pick up and SD Card reader for next to nothing these days so cost should not be an issue. Just don't get one that is too cheap as it may corrupt your card.

When you browse the File System you will see that there are multiple folders in the DCIM folder, these folders roll over when your camera hits 9999 photos.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.