2

What would be the best way to increase Lightroom performance on my machine? I'm using the latest Cloud version from Adobe.

I have:

  • Intel Core2Quad Q8300
  • 8GB DDR2 RAM
  • AMD HD3450 (old, OpenGL 2.1 support... not supported/working in LR)
  • Windows 7 Pro 64bit
  • 7200RPM HD across the board

The issue I'm having is that using the spot removal brush (currently tons of adjustments), will make LR laggy and I have to wait for the brush to come where I need it.

I tried on my Samsung R580:

  • i3
  • 4GB DDR3
  • Nvidia 310M which supports OpenGL 3.3 (which is also the minimum on LR)

LR seems to be using the GPU as there is no indicated errors like with the HD3450.

With both machines, the same image will render a very laggy experience, where the cursor seems to catch up to where I need it to be.

Edit #1

  • I have the latest version: 2015.3 (LR CC)
  • My catalogue is 77MB
  • The image giving me issues at the moment is 70MB in TIF format
  • I typically don't have an issue, but those times I'm working with RAW files
  • I unchecked the Catlogue setting that writes metadata to the TIF file, same performance issue.
  • The amount of spot removal brushes, when activated, looks like I added snow to the picture :)

Edit #2

  • Moved catalogue and cache folder to another hard drive
  • Gave LR more cache to work with (default was 1GB), increased to 10GB

Problem persist. Lightroom will hover at 25% CPU just moving the cursor around in my mine field of spot adjustments.

Edit #3

File was tried on a friend's laptop (i5, 16GB DDR3) and there was some lag noticed.

  • @dpollitt Added some answers, reading up more too. – TekiusFanatikus Jan 2 '16 at 19:50
  • @abdul-n-quraishi It's a wired Logitech. FYI. – TekiusFanatikus Jan 2 '16 at 20:02
  • @TekiusFanatikus - Try this - Under Lens Correction, uncheck Profile Corrections and see if that helps – Abdul Quraishi Jan 2 '16 at 20:15
  • @abdulNQuraishi Nothing is enabled in that tab. I wonder, this TIF is from a scanned picture. Not your typical RAW development. Would this be the cause maybe? – TekiusFanatikus Jan 2 '16 at 20:18
  • 1
    @TekiusFanatikus - Sorry, didn't realize it was a laptop. Are you at least working on A/C power, many laptops run lower performance from the battery and even turn off discrete graphics? Unfortunately though, memory speed often makes MUCH more difference with laptop graphics since it is shared between the CPU and graphic chip, so there is more bandwidth being used. – Itai Jan 2 '16 at 20:32
3

For the amount of spot removals I did, I believe I should have used Photoshop instead:

The Spot Removal Tool and Local Corrections Brush are not designed for hundreds to thousands of corrections. If your image contains many (hundreds) of localized adjustments, consider using a pixel-based editing application such as Photoshop for that level of correction.

https://helpx.adobe.com/lightroom/kb/performance-hints.html

1

A few options that I have used in the past that may also help you improve performance are;

  1. Run Lightroom in 64bit. This will allow you to increase RAM usage to 4GB instead of 2GB
  2. Increase the Cache Size. Really helps with RAW files
  3. In catalogue settings, uncheck the "automatically write changes to XMP". With this checked, every time you make an adjustment, the processor has to do double the work.
  4. Ensure that you have at least 25% free space on your hard disk.

I am sure there are many other hacks, these are just some that I have used in the past and noticed a significant improvement in performance.

Hope they help you too

0

On my desktop I switch over to what I call Smart Preview mode. You can simply do this by renaming the folder that your pictures are in outside of Lightroom, e.g., “Renamed” folder to “Renamed1”. What happens when you do this is Lightroom loses track of the pictures because you renamed the folder outside of Lightroom that the pictures were in and it responds by loading the Smart Previews it generated for processing. You should experience better performance.

Also note you must have selected the Build Smart Previews during import. If you haven't you can in the grid view go to the Library menu > Previews > Build Smart Previews.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.