2

I'm trying to connect my EOS 50D to my computer, in order to use Canon's EOS Utility to change the copyright strings that get embedded in the raw files created by the camera. Since I run Linux, this has the additional complexity of being done in a VirtualBox VM, which runs a 64-bit Windows 7 as the guest OS.

Seemingly no matter in which order I try to boot the VM, physically attach the camera (to the host), logically attach the camera (to the VM), start the software, and whatnot, I can't seem to get past the "Connect an EOS camera" prompt from the EOS Utility Launcher.

I have tried using the 19.0 software that was bundled with the camera (which didn't acknowledge any camera either) and the 29.1A software which is the most recent available on Canon's web site at this time.

A device for the camera does show up in the Windows Device Manager (so Windows is detecting the camera), but reports as its status "The drivers for this device are not installed. (Code 28)" If I logically remove the USB device from the VM, then that device disappears.

I didn't think to have the camera connected when I originally installed the EOS software, but neither was there any prompt to ensure the camera was connected.

I'm almost certain that I have done this the same way before, when I set the copyright string that is currently set in the camera.

How do I get the EOS Utility to detect the camera and launch? (Please try to avoid telling me I need a physical system running Windows...)

Note: mattdm suggested in a comment to try using ExifTool to change the value of the copyright field after the fact. Running exiftool "-Copyright=TEST" filename.cr2 does indeed appear to set the field to a different value, which provides a workaround. It would however be nice to be able to have the camera set the proper value originally rather than editing it after the fact. (It also seems to have some side effects, including an apparent reorganization of the raw file data, as evidenced by running diff -u <(exiftool -v filename.cr2) <(exiftool -v filename.cr2_original) afterwards.)

  • 6
    Probably better on Superuser, since this is a technical question about USB passthrough, rather than about photography. – mattdm Dec 24 '15 at 22:21
  • That said: can you change the copyright information with Exiftool? It can handle RAW files including a lot of makernotes – mattdm Dec 24 '15 at 22:22
  • @mattdm I wasn't sure whether to post it here (because it is specifically about photography software; I'm having trouble with EOS Utility, not USB) or on SuperUser (because it is about computers). If it's off topic here, by all means please migrate to SuperUser. – a CVn Dec 24 '15 at 22:22
  • @mattdm ExifTool does seem to work, with side effects. Thanks for the suggestion. You may want to see my edit. – a CVn Dec 24 '15 at 22:36
  • This might actually qualify for a bug report to the VirtualBox team. You may want to try with a Windows installed in vmware in the mean time. – Thorbjørn Ravn Andersen Dec 31 '15 at 8:00
3

This is a problem I have come across and solved using other usb devices to connect to a virtualbox VM. So hopefully this will solve your problem.

The solution is to set the number of CPUs in the virtual machine to only 1. You do this from the Virtual Box Settings for the virtual machine. Power down the Virtual Machine. Then in its settings select 'system' and then the 'Processor' tab. Adjust the number to 1.

Obviously you will also need to set a USB Filter to match your usb device. To get the USB Filter setting working first of all I tend to not narrow down the Vendor ID and Product ID in the USB Filter Details (accessed via the Settings of the Virtual Machine and then selecting the edit icon of filter). Once you are happy with it working then you can set those Filter Details so it works just with your USB Device and not all USB Devices.

I believe this situation is a known limitation of Virtualbox and Oracle seem in no hurry to make Virtualbox USB filters work in a multi-cpu virtual machine.

Good luck and please tell us if this solves your problem !

Bernie in Essex, England.

  • Nice to know for future use, although I usually have the host as windows and VM as Linux and sometime different windows versions for testing. – den miol Jun 7 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.