1

On my Canon EOS Rebel T2i, in automatic mode in low light, the flash raises as expected. However, after the flash raises, I continue to hear the clicking of the flash raise mechanism, and then I see the following message:

Err 05

The built-in flash could not be raised.

Turn the camera off and on again.

I cannot take any pictures with it in this state. Of course, I have tried tuning it off and back on. It seems that the mechanism that detects that the flash is up is malfunctioning. Is this something I can clear myself (maybe by blowing compressed air or something? Or resetting something in the settings?) I don't see anything in the flash area that is obviously a problem. Or should I just take it in for service?

Has anyone else experienced this issue?

  • A couple of wild guesses here: 1) If you have compressed air at hand, you could give it a try and let us know; I guess it's very unlikely that you'll damage it. 2) By the sound of it I'd guess service could have it done from one day to the next. – Roflo Nov 27 '15 at 15:25
  • Have you checked that the microswitch on the hotshoe that detects an external flash is mounted isn't jammed? See this POTN post. – inkista Nov 27 '15 at 17:53
  • 1
    Thanks @Roflo, the compressed air didn't help. I took it in to a local camera shop, since I called Canon, and they told me it would be $190 minimum do do anything... hopefully the local guys can do it cheaper. – pkaeding Nov 28 '15 at 0:30
  • Thanks for the tip @inkista, but I don't think that was it, since I did hear the clicking (repeatedly, actually), and the flash did pop up-- the problem seems to be in the mechanism that tells the camera that it popped up. – pkaeding Nov 28 '15 at 0:31
  • Ah, well. Good luck then. Do post an answer when you know what the issue was. – Roflo Nov 28 '15 at 1:14
1

I have experienced the same problem after the external flash is detached from my canon camera(T5i). The problem solved after i turned the camera off and on again. I think this is the problem in the software driver. Have you tried resetting all the settings or factory reset? If not try it, it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.