-1

I took photos today using a Canon 50D with a 64 GB Kingston card. When I turned on the camera after I got home, it said that the card was not formatted. I could not mount the file system using a USB CF card reader either using Windows 7, OS X Yosemite, or Ubuntu 15.04 .

When I tried to use recovery software (e.g., PhotoRec, and TestDisk), it didn't work because it could not find the drive to begin with.

  • Have you try to use USB cable and check if the card can be read via camera? – Romeo Ninov Sep 26 '15 at 18:23
  • Romeo: yes I tried but had no luck. The files don't show up on the computer either. – wsw Sep 26 '15 at 18:28
  • You can do few more check: use another reader, try few shots with other CF card and check if they are readable – Romeo Ninov Sep 26 '15 at 18:30
  • 1
    Agreed. The worst part is that I have to spend 2 hours retaking the photos tomorrow. I am definitely not buying Kingston products again, as the faulty CF card is barely 1 year old. – wsw Sep 26 '15 at 18:55
  • 2
    Sounds like the card is dead. This is usually due to the wires inside, not the real flash ram itself, and could be recovered professionally. Be sure to complain to Kingston: you pay for the name-brand, take them up on the lifetime warranty! Also beware of counterfit cards. – JDługosz Sep 27 '15 at 1:41
1

I know I am replying to this post late in the game, but it sounds like the card data may still be able to be recovered by a data recovery lab. they would have the expertise to be able to do "surgery" on the card and get to the memory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.