1

I have a Canon 70D with a Canon Speedlite 580EX II.

This may be a duplicate question, but I can't find the answer.

I can't get the flash to go off in live view mode, either the external flash or the pop up flash. Is this a setting within the camera that I need to adjust in order for the flash to fire?

1

The reason why the flash isn't triggering is because you have silent shutter activated on your camera.

To disable it on your 70D please go to the Camera 2 Tab of your menu and then change the Silent LV Shoot setting to disable. http://web.canon.jp/imaging/eos70dshootingguide/function/index.html

Have a look at these different articles: http://martybugs.net/blog/blog.cgi/gear/lights/Triggering-Flashes-While-Using-LiveView.html http://www.p4pictures.com/2011/02/live-view-mode-and-flash-on-your-eos-dslr/

Edit

Normally Canon speedlite disable the Silent shutter. However your flash model is 6years older than the camera so it might not have that feature.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.