I just spent a day shooting photos with a friend. The friend refused to use my Nikon and used her Canon instead. The files are .CRW and I have a Nikon D5300. When I open the card on Windows Explorer, the card shows it has used space but doesn't show the files (note I have "show hidden files" turned on.) Is there a way to find these photos without either hunting down a camera to upload or buying a SD card reader?

3 Answers 3


I'm guessing you are trying to import the Canon raw files through connecting the Nikon camera to your computer? That won't work. You need an SD card reader. (Your laptop/computer should have one?)

  • Didn't realize i left that detail out, yes i was trying to upload through my camera.
    – John Snow
    Nov 25, 2015 at 8:24

Unfortunately, if the files aren't showing up in Explorer, then the most likely explanation is that they were never written to the card at all for some reason.

A couple of things to check before giving up:

  • All modern Canons which can shoot RAW use the .CR2 extension, rather than .CRW.
  • The files will be in a different folder from where your Nikon would have placed them - probably "DCIM/100CANON".

If neither of those work, by all means double check with a card reader, but don't hold out too much hour at this stage.

  • 1
    If the Card is connected via a Nikon Camera, there is a big possibility that the CRW/CR2 files don't show up in explorer because the camera firmware hides them...
    – Vertigo
    Sep 14, 2015 at 18:00

Your D5300 is likely set up to use Media Transfer Protocol (MTP) or Picture Transfer Protocol (PTP) when connected to USB. In those cases, the firmware in the camera is going to look in the expected (Nikon-specific) location for images and not find any.

Most Nikon bodies have a setting that will change the behavior of the USB interface from using MTP or PTP to Mass Storage Class (MSC). MSC mode effectively turns the camera into a card reader, and any system you plug it into will see it as an external disk and allow you to get at everything on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.