1

How can I import a file into Adobe Elements from a Nikon D7000 when the file format is NEF and it tells me I'm using the wrong file type?

  • What version of Elements are you using? – MikeW Sep 7 '15 at 0:26
  • I am using the version photo Elements 9 – user41678 Sep 7 '15 at 0:30
  • 1
    Do your Adobe updates for your Elements. This says ( adobe.com/support/downloads/detail.jsp?ftpID=4920 ) that that ACR 6.3 adds the D7000. Normally we have to buy a new version to get it, but it says Elements 9 can accept ACR 6.3. So do the the update (in your Elements Help menu). – WayneF Sep 7 '15 at 1:34
1

Each camera/sensor has a specific version of the raw file format used by the camera maker. (.nef for Nikon, .cr2 for Canon, etc.). In order for an application such as Photoshop Elements to be able to open raw files from a newer camera, the application needs to be updated with the instructions for how to handle raw files from the newer cameras.

The version of Photoshop Elements you are using is older than your camera.

In the case of Adobe products, these instructions are included in the Adobe Camera Raw plugin, which is used by Photoshop Elements, Lightroom, and the full version of Photoshop. In order to open the files from your camera, you need a newer version of ACR that is compatible with your camera.

Unfortunately, Adobe chooses to only make newer versions of ACR compatible with newer versions of their applications (*PSE, Lr, PS, etc.). So in order to use an updated version of ACR that includes the instructions for your camera's sensor, you may need to update to a version of Photoshop Elements (or other Adobe application) that supports it.

You can look here to see which version of the ACR plugin you need for a specific camera. The chart also list the oldest version of Adobe Lightroom that supports that version of ACR. To see what versions of other Adobe products are needed for a specific version of ACR, look here.

In your specific case, Photoshop Elements 9 shipped with ACR version 6.1. Your Nikon D7000 requires ACR version 6.3 or newer. Since the latest version of ACR that PSE9 supports is version 6.5, you only need to update your ACR plugin for PSE 9 to be able to handle .nef files from your D7000. Please follow the instruction at this link.

Not the answer you're looking for? Browse other questions tagged or ask your own question.