I've just got my first DSLR (an old Canon 1000D) and I'm having problems with autofocus:

When I'm in full auto or any scene mode (sport, portrait...) it works fine and I can make photos normally, but when I'm in P, Tv, Av, M or A-DEP, the camera doesn't seem to detect that I'm in autofocus. It tells me that I'm in MF (even though I'm not) and doesn't focus. I have to turn to MF if I want to use these modes, which is sometimes a problem.

I've cleant the contacts, checked that I'm in AF, checked the configurations and I can't see the reason. It happens in two diferent objectives (Canon and Sigma) and does not depend on the image (not too close, too dark problem).

It may be broken, but I don't know since it works just fine in some modes. The camera is not on warranty since it is an old camera from a relative.

Any help will be very welcome.

Edit: I forgot to say that I still can make photos in AF even though they are blurred.

  • 1
    I don't think any configuration of settings on the Canons I've used would result in this behaviour. Never used a 1000D though. Jul 29, 2015 at 16:43
  • Are you trying to focus with a shutter-button half-press? (have you tried the *-button on the back instead?)
    – inkista
    Jul 29, 2015 at 20:20
  • I was trying with a shutter-button half-press. I have just tried with the *-button but it doesn't work in manual nor scene modes. (I am trying just pressing the *-button in AF and it does not focus, I don't know if I have to do something else, I'm pretty new in this world. But also, the camera does not recognise that the lens is in AF except in the scene modes)
    – Javier
    Jul 29, 2015 at 21:47
  • Are you composing through the viewfinder or using Live view?
    – Michael C
    Jul 29, 2015 at 22:34
  • Usually through the viewfinder, but i just checked and the same problem happens in Live view.
    – Javier
    Jul 30, 2015 at 14:38

4 Answers 4


I am sorry, I have just made a typical mistake. I had not tried to erase all configuration data in the camera before asking (with the option in the menu).

I though I had tried changing every related option but it seems I left one of them. Just restoring the configuration to preset values has made it magicly work.

In the end I still don't know why it happened, but well... it is fixed somehow.

Thank you very much for your help and time. I like this forum, I will try to help in the future.


Autofocus works when you turn on the AF on your lens and hold the shutter button half way down and let the camera do the trick. Have you tried that?

  • That is what works in the scene modes but not in the "manual" (I think they are also called artistic) modes.
    – Javier
    Jul 29, 2015 at 21:39
  • 1
    Welcome to Photo.SE. Your answer may have been voted down because it helps to ensure that your answer is relevant to the information given by the original poster; in this instance, the poster had already indicated that autofocus works fine in "auto" modes, which implies that they already know how to ensure AF is turned on, and how to activate it.
    – Conor Boyd
    Jul 29, 2015 at 22:38

Are you shooting in Live View? If so, to focus you should press the AE Lock button <*> on the back of the camera. Half pressing the shutter will not activate Auto Focus in Live View.

If you are shooting using Live View and have Custom Function C.Fn-7 set to 0: Disable neither a half press of the shutter nor pressing the AE Lock button <*> will activate Auto Focus. In this case, to enable back button Auto Focus set Custom Function C.Fn-9 to 1: AE Lock/AF. With this setting selected, pressing the shutter button will only lock exposure, to initiate auto focus press the AE Lock <*> button (that has been remapped as the AF button) on the back of the camera with your thumb.

  • Thank you for the detailed answer. I have just tried with that configuration and it still does not work. It locks exposure with the half pressed shutter, but nothing happens when I press the *-button.
    – Javier
    Jul 30, 2015 at 14:46
  • If you have the <*> button set to lock exposure does it prior to recomposing and taking the shot does it do so? Or do the exposure parameters (Tv, Av, ISO) change if you press the <*> button while pointed at a bright light source and then hold the <*> button while recomposing to point at a dark area? Or vice versa by metering and pressing <*> while pointed at a very dark area and then holding down <*> while pointing at a very bright area?
    – Michael C
    Jul 30, 2015 at 23:36
  • Thank you for your help. The problem was finally solved by resetting default configuration settings. Nonetheless, for the sake of curiosity (I still did not know why it happened), the <*> button did lock the exposure parameters when pressed.
    – Javier
    Aug 2, 2015 at 20:56

Does this camera support back-button autofocus?

The reported behavior matches what my 6d does, sort of—I have it set to move AF from the shutter button to a button on the back, but green box overrides that setting and puts AF back on the shutter button.

  • Thank you for the answer. In the end it was not the problem, but now I am curious, what is "green box"?
    – Javier
    Jul 30, 2015 at 15:12
  • The auto-everything hand-it-to-a-stranger mode on my 6d is indicated by a little green box on the mode dial. Aug 1, 2015 at 9:24
  • Oh, yes, it is also a green box in my camera, I thought it was a technical term :)
    – Javier
    Aug 2, 2015 at 20:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.