Couple quick points (after a lot of googling with no answer):

  1. It's not the switch. The switch on the card is in the unlocked position. I just checked again, just to be sure.

  2. All the similar problems I've found on forums, etc. related to a damaged card, camera had been dropped, etc. All my equipment is in good condition. Pristine, even.

So! The card works as normal in the Nikon D3300, no problems. When I plug it into my computer, the card is read-only. Anyway to fix it? FWIW, I'm on a Mac. Thanks for your help!

  • 2
    How was the card formatted? – mattdm Jul 19 '15 at 9:49
  • I understand the problem, but... is it a problem? I only ever read cards from the computer; don't even know if I can write to them. Reformat in the camera, and start shooting again. – Dan Wolfgang Jul 19 '15 at 19:17
  • when you say read only - are you saying you cannot delete any pictures from the SD card? – azngunit81 Jul 21 '15 at 22:58
  • The problem is not with the lock tab. I have the same problem with my D600. I detected it when I was trying to update the firmware in the D600. The problem is that once I format the SD card in the camera I can no longer write any file on it from the computer. And to make the firmware update you need to copy the file in the sd card!! I don´t know how to solve this problem. – user67626 Aug 16 '17 at 12:11
  • @mattdm I'm fairly sure the card formatting is the problem. I have a Mac and it cannot natively write to cards formatted by Nikon cameras. There may be some software which allows for writing though. I'll check tonight. – tittaenälg Aug 16 '17 at 15:29

Assuming you're talking about an SD card, there's a possibility with some cards with very easily shifted write-protect tabs to get shifted into read-only position upon insertion into certain readers, and shifted back upon removal, by any slight friction. I've had this happen a couple of times, and it seems like kind of a perverse design to me (I've actually cemented the slider into place on one of my cards). You might want to investigate this possibility. Also, possibly relevant link.


The lock switch on an SD card is a simple physical mechanism. The card reader feels for a gap where the lock switch should be, and if it feels a gap it write-protects, but if the tab is there it enables write.

(If the lock switch breaks off, you can put masking tape where it used to be, in order to be able to write to the card. It's basically the same principle as these if you are old enough to remember.)

As you've said, the switch is in the correct position, and the problem occurs when the card is in the computer, so we can probably rule out the camera being the problem - the problem is likely to be the card, or the reader in the computer.

To troubleshoot, try different cards in the card reader on the computer and see if it writes to them. If you have other card readers, try the same card in other card readers.

I think the problem is likely to be one of the following:

  • Tab on card is broken, and it's not quite sitting in the right position, or staying there when you insert it in a reader.

  • Lever in the card reader that feels the presence of the tab is broken.

  • Card or reader is a cheaper brand and the shape of the card, reader, write-protect tab or lever is not quite in the right position.


I have seen at least one brand of SD card (sorry, can't remember which - was years ago) where the label on the read/write switch was back to front, so the 'lock' position was actually the 'unlock' position. I suggest you flip the switch and see if that fixes your problem.


Apparently the internal SD card reader in MacBooks can be quite finicky, and tends to assume the write switch is always in the "No" position.

As @junkyardsparkle mentions in the link at the end of his or her post, some people have been successful in gaining write ability by setting the write switch to the middle of its range. I tried this a few times but have yet to be successful. There are at least two blog posts and a YouTube video recommending this method however, so maybe it just takes some practice to find the right spot for your card.

Alternatively, what has worked for me is using an external USB card reader.

I ran through a few iterations of internal/external card reader with the write switch on/off and the external reader always read the card correctly, while the internal reader always assumed the card was write-locked.


The simple way is to access a windows machine and use that to upgrade the firmware. It worked easily for me, I used my windows laptop. I say 'simple' reservedly as I'm assuming most mac users can access a windows machine, either one of their own or one belonging to a family or friend.

Sometimes we can get bogged down looking for a technical mac-based solution where there might be simpler alternatives.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.