I have a Yongnuo YN-560 III and a pair of RF-603II (C3) triggers. I have a Canon Rebel T5i.

I put one trigger on the hot shoe. When this trigger is in TX mode I get a blue comm light and I can fire a test flash using the large test button on the trigger. But when I press the shutter button to take a picture, there's no flash.

The trigger and flash are on Channel 1. The trigger on the hot shoe is set to TRX. TX is fine, TRX gives me no flash. The flash and camera are in M mode.

I don't have a trigger on the flash because the Mark III has a built-in trigger The problem seems to be the camera. The trigger can talk to the flash but the camera is not sending a flash command through the trigger in the hot shoe to the flash.

Grateful for anything you could suggest.

  • \$\begingroup\$ Have you tried to use the pcsync cable (between your camera and transmitter)??? \$\endgroup\$
    – user55618
    Commented Aug 9, 2016 at 17:41
  • \$\begingroup\$ I hate to add "me too" comments but this question is some years old and doesn't appear to have a good answer yet. I'm having exactly the same problem, Canon 800D (Rebel 7), a pair of RF-603II (C3) triggers and a Nikon flash. I can push the test button on the TX trigger and the flash fires. I push the shutter button on the camera and the flash does not fire. \$\endgroup\$
    – delatbabel
    Commented Jan 14, 2020 at 14:13

2 Answers 2


Try removing the trigger from the camera hotshoe, and connecting it while both camera and trigger are switched off. Screw the thread down properly, then turn on the trigger, then turn on the hotshoe.

Also, the flash won't fire i think if any sort of silent shooting mode is enabled in Liveview, so if you are using Liveview, there is an option in one of the menus to set 'Liveview silent shooting' to disabled, or Mode 0: off or something along those lines


Try connecting everything while it's all powered down. Power up the triggers first, then the camera/flash.

Things to check on your YN-560III:

  1. Is it set to RF-603 or RF-602 compatibility? If it's set to RF-602, it won't respond to your RF-603II. (This is a custom function on the flash).

  2. Make sure it's in the group you want.

  3. Make sure it's on the channel you want (i.e., that the dip switches in the RF-603II's battery compartment match the channel you've got displayed on the flash).

  4. Make sure it's got freshly recharged batteries in good health.

  5. Make sure it's in RF slave mode (RX). NOT S1/S2/Sc/Sn. Those modes tell the flash to listen to the optical sensor panel, not the hotshoe, not the radio receiver.

Things to check with the on-camera RF-603II.

  1. When in doubt, set it to TX, so it doesn't automatically try to make itself a receiver.

  2. Make sure you've got it oriented the correct way, with all the pins seated correctly on the contacts on the hotshoe. Slide it as far forward as you can, to make sure it's correctly seated. The transmitter not being correctly seated is a very common problem.

  3. Make sure you're using the group/channel you have set on the flash.

  4. Make sure the batteries are freshly charged and in good health.

I would also mention that the YN-560-TX might actually be better than a set of RF-603IIs if you're only using a single off-camera YN-560III, as it will give you remote power control over the flash.

Also make sure in the camera flash control menus that Wireless is disabled. That's for the optical system.

  • \$\begingroup\$ Thanks for those suggestions, will try each of those when I get home from work. \$\endgroup\$ Commented Jul 13, 2015 at 18:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.