1

When I plug my camera into my PC using the USB cable, and open Photoshop Elements, I no longer see my camera in the drop-down list when trying to acquire/download images. The camera is on, the battery is good, etc. (I've done this "a million" times in the past).

What is the most likely problem? I'm thinking the cable has given up the proverbial ghost, but I don't want to spring for another cable if there's something else I can try first.

It's a Canon "Digital Rebel", about five years old.

migrated from meta.photo.stackexchange.com Jun 1 '15 at 19:38

This question came from our discussion, support, and feature requests site for professional, enthusiast and amateur photographers.

  • I'm voting to close this question as off-topic because it seems to be a better fit for superuser.com – dpollitt Jun 2 '15 at 1:15
  • 1
    Can you see the camera in "My Computer"?, have you tried a different cable? – Digital Lightcraft Jun 2 '15 at 8:29
  • As mentioned, I am holding off buying a new cable, because I don't want to do that if it's not necessary. Where would I look in "My Computer" to find the camera? Should it populate an "installed hardware" section or some such? – B. Clay Shannon Jun 2 '15 at 15:36
  • 1
    vtc b/c OP already knows what the likely cause of the problem is, but doesn't want to do what's necessary to resolve it or find the underlying problem (use a different USB cable). – xiota May 23 at 4:35
0

What is the most likely problem? I'm thinking the cable has given up the proverbial ghost...

Since your camera seems to be otherwise functional, the likely cause of your problem is, as you've already noted, most likely a damaged USB cable. This is a common problem, and the solution is to use a different cable.

Even if the cable is not the problem, ruling it out should be among the first things you try because it is cheap and easy.

I don't want to spring for another cable if there's something else I can try first.

USB cables are generally not worth trying to fix, and if you've already tried the usual disconnect-reconnect-reboot routine, there's not much left to "try". If you're willing, I suppose you could try a total reinstall of your OS and PSE, but most people would prefer to leave that as a last resort.

If you don't need to import directly into PSE, you can transfer images by other means, such as with a card reader.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.