So I shot photos for my robotics team at an event this weekend and ~95% of them are corrupt. The JPG previews from the camera are fine, but when Adobe Bridge generates its own preview, the corruption becomes visible. It is also visible in Camera RAW, and Finder (Mac OS file manager)

Is this fixable? If not, how do I prevent this in the future? I'm thinking that maybe this is just bad header info (I don't know how NEFs work but it looks like they store color in different channels, and the channel information is mismatched.)

I used a Nikon D5100, shot in NEF (RAW), and no error messages ever appeared on the camera. The camera appeared to be working perfectly normally, so I didn't even notice the problem until after the event was over.

I don't think this is a duplicate of Why do images get "corrupted"?, because that case did not produce a similar looking aberration so I think it was corrupt in a different manner. Also I do not have images with large chunks missing, just channel issues. Also that question does not have any answers detailing how to fix the images for my situation (since I don't have multiple images of the same thing to stitch together)

Take a look: Screenshot of corrupt image 1 Screenshot of corrupt image 2

  • 2
    \$\begingroup\$ Looks like a duplicate to me: as the answer says, the most likely explanation is a bad SD card. I'll retract that close vote if you try a known good SD card and get the same result. \$\endgroup\$
    – Philip Kendall
    Apr 6, 2015 at 5:56
  • 1
    \$\begingroup\$ It is always a good idea to format the card at the start of any shoot. that gets rid of any existing corruption, or at least helps you ID a failed card before it's too late. This is classic for failed or corrupted card. \$\endgroup\$
    – chuqui
    Apr 6, 2015 at 7:20
  • 1
    \$\begingroup\$ That the particular pattern is different is probably just because your camera lays out the JPEG files slightly differently from the other, and/or that the bits corrupted are in a different place. \$\endgroup\$
    – mattdm
    Apr 6, 2015 at 17:34
  • 1
    \$\begingroup\$ @danielcg Sorry, missed that, but... basically, that's in agreement with what I said. It explains why the pattern looks different, but fundamentally data is scrambled or missing. \$\endgroup\$
    – mattdm
    Apr 6, 2015 at 19:40
  • 2
    \$\begingroup\$ @mattdm is right - I've added an answer, it doesn't look like missing data, more bad data which means the copy process probably went wonky for a few bytes in each of the affected images. \$\endgroup\$ Apr 6, 2015 at 20:11

2 Answers 2


What you're seeing is consistent with data corruption in that the preview lo-res jpeg is fine, and that the compressed raw has a number of incorrect or missing bytes causing corruption.

The question Why do images get "corrupted"? describes the effect at the file level. Use of a different file format (raw rather than jpeg) will give you different output but the underlying causes and resolutions are the same.

The accepted answer there says...

Likely culprits, in order of probability:

•Bad SD card (by far the most likely, especially with cheap cards).

•Bad cable or card reader (more common than you might think).

•Something wrong on your computer (many things can go wrong!).

•A bad connection inside the camera.

•Something horribly wrong with the camera's electronics.

The "bad card" scenario is, unfortunately, the most likely, and in that case the pictures are lost. If it is just the reader or cable, transferring the files again might work — but you've probably already tried that. Checking on a completely separate computer is another good diagnostic step.

and a note on the answer says:-

Turns out...it was the USB ports on my PC. Because when I connected my Nikon to my Macbook Pro, it copies all the images perfectly, and the above images came out nicely. So it is bitter sweet. Now I know what's wrong, it just turns out to be all my USB ports

Given that it's only a byte or two out of place this commenter's resolution is likely to be similar to yours since USB has no error checking, if a transfer problem occurred it would generate problems like this.

Try the card in an external card reader or on another machine, copy the files again and see how you go.


For me this looks like storage card is broken. Replace it and test again

P.S. And IMHO you can't fix the photos. You can try software like recuva to recover the files, but it's not sure what result you will get


Not the answer you're looking for? Browse other questions tagged or ask your own question.