5

When I try to connect to D5300 built-in wifi from my Android phone (WPS password correctly entered), I'm asked to provide a password to complete the WPA2 connetion.

enter image description here

enter image description here

I've no clue which password I'm supposed to enter, nor how to set-up such a password. All instructions on Internet assume the D5300 wifi network is open (no password required), but it seems my brand new D5300 is of a different kind.

  • Did you ever figure it out? I have the same problem and none of the above comments correct the issue. – DaveS Mar 31 '17 at 2:39
5

The camera uses WPS for WiFi security. On your android device, go to

Settings -> WiFi -> Advanced Menu -> WPS Push Button.

Then press WPS button on the camera. Here's a page from user manual explaining how to press WPS button in camera settings.

enter image description here

In a few seconds, phone should connect to WiFi.

  • Indeed the camera asks for the WPS password generated by my Android phone. I enter this password, the camera completes the connection, gets an IP address, and.... BOING!!!! The camera then asks for ANOTHER password, as if it were using WPA2 security, instead of an open connection. I've no idea what password should I use, nor I've found a way to reset the WiFi connection not to use WPA2. – Antonio Plais Apr 30 '15 at 21:25
  • Correction: the second password is required on the Android phone to access the D5300 WiFi network. The same password is asked if I try to connect a PC to the camera's network. No info anywhere on how to configure security (or disable) on D5300 network. – Antonio Plais Apr 30 '15 at 21:36
  • 1
    I've confirmed that the camera is, by default, configured to use WPA2 security when WiFi connection (WPS) is completed. So, the question is: how do I access the camera configuration to set/reset this password??? – Antonio Plais Apr 30 '15 at 21:49
  • Does the Reset Network Settings menu selection (shown in Step 2 of the diagram) do anything? – inkista Jun 28 '15 at 16:13
  • inkista, no, it does nothing related to the WPA2 password. It just "forget" the WPS password, so I've to generate and enter another one. Again, the network is WPA2-protected, and I still haven't found a WPA2 password anywhere – Antonio Plais Jul 19 '15 at 23:58
3

I had the same problem--my Nikon d5300 came with WPA2 security already enabled for the WiFi connection, and I had no idea what the password was. I was connecting with an iPad, so I didn't have the option to use WPS.

Here is how I fixed it:

1) On the Nikon, go to Menu > Setup Menu > Wi-Fi > Network connection and enable the WiFi connection.

2) Wait a few moments for the connection to be established, then, in the Wi-Fi menu, go to "Network settings" and select "Reset network settings".

Doing this will reset the WiFi to an open connection, so you should now be able to connect to your Nikon without a password.

Once you have done this, you should open the Wireless Mobile Utility app and go to the Settings menu > WMA Settings > Authentication and change it back to WPA2 (which will prompt you to set a password) to prevent other devices nearby from accessing your photos.

1

This article - although for a different Nikon model, might help you.

You set your password in order to prevent other people with smart devices within your camera WiFi signal range from accessing it and downloading your pictures, for example.

Doesn't your camera display instructions after pushing the WPS button? A generated password to enter to your smart app?
Nikon D5300 manual, page 48 - WiFi.

  • IIRC, connecting via WPS removes the need to enter a password. It just requires the connecting app to attempt a WPS connection within a short time after activating WPS on the camera. – ElendilTheTall Apr 3 '15 at 20:46
  • You're right. But for example Panasonic Lumix DMC-FZ1000 requires to enter the password shown on your camera display to your Android app in order to ensure the connected Android device is really your own device. This is not the WPA2 key though. I'll try to update my answer. – user681768917 Apr 3 '15 at 20:55
  • Indeed the camera asks for the WPS password generated by my Android phone. I enter this password, the camera completes the connection, gets an IP address, and.... BOING!!!! The phone then asks for ANOTHER password, as if the camera WiFi network was using WPA2 security, instead of an open connection. I've no idea what password should I use, nor I've found any way to reset the WiFi connection not to use WPA2. There's no mention anywhere about how to configure security on D5300 WiFi network. The same behavior if I try to connect a PC to D5300 WiFi network. – Antonio Plais Apr 30 '15 at 21:33
  • I've confirmed that the camera is, by default, configured to use WPA2 security when WiFi connection (WPS) is completed. So, the question is: how do I access the camera configuration to set/reset this password??? – Antonio Plais Apr 30 '15 at 21:49
  • Thanks for all that have tried to help me. Unfortunately, I'm still stuck here :( I'll post some images below – Antonio Plais Jun 28 '15 at 11:49
0

I ran into that myself with my D5300.

You are doing it in the wrong order.

First activate WPS on the Camera, then (within 2 minutes) press the WPS button on the phone.

If you do it the other way around (like you comments to the other answers seem to suggest) you get the behavior as you describe.

0

I've realised, indeed, that I can't use WPS the first time I establish the connection!

Before using WPS one need to:

  • turn on the WiFi network on D5300 (no WPS)
  • connect the mobile (no password required)
  • set a WPA password using the app
  • turn off the network
  • turn on the WiFi network on D5300 again (this time, with WPS)
  • enter the WPS password provided by your mobile device
  • enter the WPA password your set previously

Of course, none of these is said anywere on Nikon's manuals, website or Support pages :(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.