8

I'd like to take second and sub-second timelapse videos with my Canon 7D. I've tried both DslrDashboard and Magic Lantern, and couldn't figure out how to set the timelapse any faster than that. Worse, both of them ended up taking photos at such a jittery rate that I could hear it was completely off kilter. The camera would take one photo, then wait for a couple seconds before taking two in less than half a second, and so on, making the result unusable for video making. I was using manual focus and manual mode, with shutter time, f-stop and ISO all set to static values. I generally set white-balance manually using a grey card, but I don't remember if I did for this shoot.

The camera is otherwise perfectly capable of taking many photos per second, even at RAW quality. Is there some fundamental issue with the timing used when remote controlling (and even when using custom firmware) causing this, or did I miss an important setting to make it all work? If this is simply an issue with both these products, are there other software products which will reliably take 1 Hz or faster time lapse series?

To be clear, the question is not how to make timelapse photos as quickly as possible, but rather:

  1. How to avoid jitter, that is, the time between images deviating significantly from the preset in either direction.
  2. How to take sub-second timelapse series, not necessarily anywhere near the hardware limit. I know of no software which allows for even 1/2 second delay between photos.

I have two memory cards, one which says "UDMA 7" and the other (a Sandisk Extreme) which says simply "UDMA". I don't remember which one I used, but AFAIK both of these should be more than fast enough.


I did a double check using Magic Lantern, to quantify the results. I set it to take 1 FPS, set focus to manual, ISO 100, disabled bracketing, set quality to small JPEG, set drive mode to single shooting and turned off preview. In 390 seconds it took 389 photos. Sounds accurate enough, but that's until we consider the jitter. If the timing was jitter free there would be exactly one timestamp with zero photos, and all the rest would have one.

Number of photos per timestamp

To summarise the graph, 173 timestamps had 0 photos, 45 had 1 photo, and 172 had 2 photos. So it looks like the either timer is way off, or the camera is not recording timestamps in the EXIF tags appropriately.

Now the question is: What could still be causing this? Please note that this operation produced very small amounts of data compared to normal shooting (each image was only ~2 MB).


The Triggertrap app+kit is another interesting solution, but I've two reservations:

  1. Their web page seems to be falling apart, with several broken links encountered within minutes. If the company goes under without first open sourcing their software I fear the app will not be maintained and the kit will be useless as soon as I get an unsupported phone. I would be happy to be convinced otherwise - maybe the app functionality can be replicated easily - but longevity is a major concern.
  2. After the disappointment with the other solutions and Triggertrap issues with Android audio, I'm wondering just how fast the app can actually trigger on my camera. Betting 30 quid on it seems a bit premature right now.
  • 2
  • I don't understand what's unclear. Could you please point out how the question could be clarified, and in which way it doesn't belong here? I thought this site would be the perfect place to ask a question about photography hardware/software limitations. – l0b0 Apr 2 '15 at 22:31
  • 1
    Have you tried a hardware intervalometer? I don't see why the need for software when a $12 piece of non-OEM hardware should accomplish this quite well. – dpollitt Apr 2 '15 at 23:03
  • 6
    Perhaps the randomness of shutter release is being caused by the camera struggling to lock the focus? Maybe try manual focus as well to see if that removes the jitter. – dav1dsm1th Apr 3 '15 at 1:00
  • 1
    I think davidsmith hit on a critical point. Is your focus manual, or set to AF? If set to AF, and AF is linked to the shutter, and you have the AF system set to lock focus before releasing the shutter, then you are very likely experiencing focus hunting which is resulting in the inconsistent timing. I would make sure your set to manual focus, manually focus on the area you want to expose, set a tighter aperture for deeper DOF, and see if that fixes the issue. – jrista Apr 3 '15 at 16:40
8

Several things could be going on. Based on the question as originally written you might have been experiencing buffer congestion. When the buffer is full the camera must wait until enough space has been sufficiently cleared from the buffer as the data is written to the memory card before it can take the next frame. Under such conditions, the "double tap" then pause is normal behavior.

Some things you can try to stretch the buffer further:

  • Save your images as jpegs instead of raw .cr2 files. The smaller size of the jpegs allow them to be written to the CF card much more quickly. With versions 1.xx.xx of the 7D firmware, the buffer will fill after about 15 shots. By contrast, the buffer won't fill until around 94 large/Fine jpegs have been taken. Versions 2.xx.xx of the 7D firmware, released in 2012, increase the buffer to around 23 raw shots and 110 jpegs.

  • Update your 7D to the latest firmware version, currently 2.0.5. You can find and download the latest versions of all of the software that came with your camera on the software disc at Canon's support page for the 7D. Version 2.x is a significant improvement over version 1.x in terms of drive speed and buffer capacity/performance.

  • Use a faster memory card. Using a UDMA CF card increases the buffer performance to 15 raw/126 jpeg (firmware versions 1.xx.xx) or 25 raw/130 jpeg images (firmware versions 2.xx.xx).

If buffer congestion isn't the problem (you've since indicated you are saving your files in jpeg format), it could be an issue related to autofocus hunting. Set the focus to the desired distance and then flip your lens' AF/M switch to M for manual. That still doesn't account for the frames taken faster than what you have set the camera for, though.

You've already indicated you are setting the shutter speed, aperture, and ISO manually to allow consistency from frame to frame. For consistent color from frame to frame I would suggest also setting white balance manually. Set it either as a specific color temperature such as 5200ºK which may also be fine tuned with the WB Shift menu item, using the Custom White Balance menu item, or even designing a custom Picture Style. You can use the Picture Style software editor included in the software disc that came with your camera to have even greater control over color correction and other items and then import your custom picture style to your camera.

Edit: Now that you've also indicated you are manually focusing about the only thing left are the ways in which you are trying to get your camera to shoot the time lapses. Consider using a stand alone wired shutter release with built in intervalometer that attaches to your camera via the N3 port. I've had good success with this one purchased over three years ago.

  • 2
    Also, depending on the final desired video resolution, choosing a smaller size is an option--Small/S-RAW is higher than HD resolution; Medium/M-RAW is higher than 4K. – inkista Apr 3 '15 at 6:32
  • 3
    Why would I get buffer congestion at 1 photo per second? – l0b0 Apr 3 '15 at 6:57
  • I am not sure how buffer congestion would be the problem at 1fps and with JPEG images. I think something else is going on...probably focus hunting or something like that. – jrista Apr 3 '15 at 16:34
  • @l0b0 Your question says "Sub-second time lapse". – Michael C Apr 3 '15 at 23:13
  • @jrista Yes. But the answer was written before we knew that. – Michael C Apr 3 '15 at 23:14
0

The Canon 7D can do fast bursts of images and does so very well, but when it does that, it will lock up the mirror at the start of the burst. When you are shooting via remote and trying to take a set of images one after another quickly, the mechanics are different because it's going to raise and lower the mirror as part of each image. That's going to slow down how fast it can shoot significantly and also raise the problems of camera shake from the mechanism movements. Also, are you in autofocus and is AF tied to the shutter button? If so, then every activation will cause the AF to re-lock, taking time and moving things around.

so, some suggestions: manual focus, turn off AF completely. Once you have focus and exposure locked in, lock the mirror up.

Even with that, don't expect to get 7-8 FPS. But I'm guessing mirror movement is the root of the issue you're seeing.

  • 2
    My 7D cycles the mirror between every frame, even at 8 fps. – Michael C Apr 3 '15 at 3:15
  • You can also set AF to "One Shot" and the camera will only perform AF before the first frame of a continuous burst and then use the same setting for the rest of the burst. But the mirror will still cycle between each frame unless you are using live view ( and not using Quick AF focus mode in LV). – Michael C Apr 3 '15 at 3:18
  • 2
    The only DSLR camera Canon makes where the mirror doesn't always cycle between frames when shooting through the viewfinder is the 1D X, and it only when set to 14 fps. When set to 12 fps the 1D X also cycles the mirror between every frame. – Michael C Apr 3 '15 at 3:21
  • Michael -- you're correct. I misremembered. Went and checked my 7D, and it does cycle the mirror. Apologies for the mis-info. so I'm guessing it's autofocus. – chuqui Apr 3 '15 at 3:35
  • The problem appears when trying to shoot 1 FPS. And several of the photos are being taken with much less than one second delay. – l0b0 Apr 3 '15 at 7:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.