I've recently switched from Picasa to Lightroom 3.3. Upon importing my pics into lightroom, there were about 500 that appeared at the top when sorted by date, despite being older pictures. Turns out that they had an incorrect "date taken" in the meta data. (May 2011 instead of 2010) So I sought a batch process to update those pictures - used jhead and it worked wonderfully. Windows Explorer now sees the corrected date taken as does picasa. However when I open lightroom, the pictures all still have the old (2011) date in the meta data under the "date time original" and "date time" fields. Is lightroom maintaining its own metadata separate from the embeded jpg file? If so, how can I get it to sync up with what's in the JPG?


2 Answers 2


An important thing to remember now that you switched to Lightroom is that you should try to do as much from there as possible. You will get used to it in no time. As you just found out, LR maintains a lot of information in its database and modifying the files on disc will put you out of sync. Another hurdle is to resist the urge to move files around from Windows Explorer; make sure you do it from Lightroom or you will soon spend some quality time telling LR where to find your old files.

Anyway, to solve your problem, select the files that are out of sync, right click and pick "Metadata -> Read Metadata from file" from the context menu or the main menu. I'm pretty sure "Synchronize Folder" works if the "Scan for metadata updates" option is ON, but this would also import new images and you might not want that.

This goes both ways of course. If you update some Metadata in LR and want to make sure it is accessible to third party apps, select your files and use "Save Metadata to File". You are probably wondering if this can be done automatically for you, and the answer is yes, by checking the "Edit-> Catalog Settings-> Metadata -> Automatically write changes into XMP" option if I recall but I would advise against it for performance reasons.

**added 7/18/13, using LR 4.4: this method does not work if you have chosen to have Lightroom export its metadata into .xmp "sidecars" (Catalog Settings->Metadata->Automatically write changes to xmp) or otherwise have .xmp files alongside RAW or similar purportedly read-only images UNLESS the tool you have used external to LR (ExifChanger, for example) has written a line for DateTimeOriginal or DateTimeDigitized into the .xmp file. ExifChanger for one does not, so the timestamp in the .xmp file never reflects the change made, but it is shown in the file's own exif data, which LR seems to ignore.

  • \$\begingroup\$ Picasa has similar limitations with folders, etc. Modifying 568 files date taken field one by one was something I'd rather not do. Thanks! \$\endgroup\$
    – Jody
    Dec 29, 2010 at 13:10

Lightroom maintains a catalog where it stores such information. From what I can tell you have two options -

  1. Synchronize folders - http://www.image-space.com/Lightroom_Tips_Tricks/Library_Module_Tips/Synchronize_Folders/Synchronize_Folders.html

  2. If that doesn't work, you could delete the catalog (usually located in My Pictures) and reimport the pictures. That should solve your problem.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.