0

I recently bought a Nikon D3100. But I have a problem now: I can't change shutter speed, ISO, or aperture in any mode. I am stuck at 1/100 and when I try to wheel it shows me 1/80 for a second and then switches back to 1/100. Same for other settings. When I switch to automatic the settings change.

Same in the image view: I switch one forward it switches back.

How can i fix it? I have tried to reset settings, but that didn't work.

  • 1. Have you made any changes, e.g. to firmware? 2. Have you tried removing battery, waiting a few minutes, and reinserting? – DrMoishe Pippik Mar 19 '15 at 14:36
3

Maybe a stupid question, but are you in manual mode?

Have you tried resetting all settings to their original value? This is how you do it (From the Nikon website):

Resetting the D3100 The D3200 and D3100 do not have a 2 button reset option. To perform a reset you need to manually choose the reset option in the Shooting Menu and the Setup menu. To do this press 'Menu', select the Shooting Menu and scroll through the options until 'Reset Shooting Options' is highlighted, press ok, highlight 'Yes' and press ok again. Repeat this for the Setup menu.

I know from my D5100, that you can set ISO-sensitivity to automatic, this overrides the manual controls. This setting can be found by going:

Menu->Shooting Menu (The one with the camera icon) ->ISO sensitivity settings-> Auto ISO sensitivity control , and set that to OFF

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.