My D5200 has developed a problem, every time I turn it on I get the error message "This memory card cannot be used. Card may be damaged Insert another card." I have tried multiple memory cards in the camera and tested them on another camera to ensure that they work but the message still shows. I followed following instructions from Nikon but problem still remain.

  1. Remove battery, Memory card, and lens for about 30 seconds

  2. Reinsert just the lens and the battery, power the camera on ensure you are using an approved card: Answer Title: Approved SD cards for D5200 Answer Link:https://support.nikonusa.com/app/answers/detail/a_id/18424

  3. The camera settings can be restored to default values by holding the "Menu" and "i" buttons down together for more than two seconds

(these buttons are marked by a green dot). The information display turns off briefly while settings are reset.

  1. Hit the menu button and select custom setting menu

  2. Select "F" for controls and then "F4" labels " Slot empty release lock"

  3. Highlight "Enable release"

  4. Test camera with no card/ then reinsert the card and try again

After this I am able to take pictures in demo mode, but the SD card still gives error.

I bought this one and half years ago from the US. I am in Canada, and Nikon wants me to send it to USA and says it will cost 400+ bucks. This is just too much for me. Can someone please suggest how to fix this?

  • Have you inspected the card slot for physical damage or anything blocking the contacts? – inkista Mar 10 '15 at 22:51
  • 1
    Look carefully in the narrow slot where the contacts are for the gold tabs of the card. If a card is inserted backwards and forced, those contacts can get bent over. It might be possible to bend them back with a fine bent probe, but more likely will require professional repair. – DrMoishe Pippik Mar 10 '15 at 23:16
  • Format the card. Even on another camera but make sure its completely blank. I've seen this happen on a Nikon 1 J5 just last week. it didn't like that the card had some hidden files introduced by a Mac. – Itai Jun 5 '15 at 16:34
  • 1
    You will save a lot of money taking it to a local repair shop. Especially since the body probably isn't worth much more than $400CAD... – James Snell Jul 5 '15 at 9:56
  • Did you try format you SD card with another camera? – Manu H Nov 12 '16 at 9:02

Here are some suggestions as to how to approach your problem:

  • Clean out the contacts within the card slot, if dirty — This can be done using compressed air, or very gentle work with pliers or q-tips with some cleaning alcohol based detergent
  • Try smaller and/or slower sd-cards — sd-cards comes in different classes/sizes, your camera might have difficulties with the classes/sizes you've tried so far
  • Upgrade firmware of camera — This is a long shot, but you could possibly have an issue with the firmware/software on your camera accessing the sd-cards, and thusly an upgrade could cure it
  • Reformat cards on a different platform — If possible reformat one of the sd-cards using the camera (if possible), or a different camera, or on a different computer
  • Insert the card at another time — You've most likely tried this already, but if you previously inserted card before turning on camera, try inserting it afterwards, or vice versa

I had the same error. Here is what I found fixed the problem:

Format using the correct SD card formatting tool, which can be downloaded from sdcard.org.

The windows formatting tool doesn't do the job correctly.

Ran this with just a quick format and it worked straight away.

  • 2
    The windows tool does the job just fine, you just have to make sure you choose the correct options. – James Snell Dec 26 '15 at 19:09
  • A camera will do the formating job just fine, no need to tune the parameters. – Manu H Nov 12 '16 at 9:01
  • @ManuH It is kind of difficult to format the card if the camera refuses to recognize the card... – Michael Clark Sep 24 at 20:31

If you are using a microSD card with adapter, try changing the adapter. This solution works for me. I've found adapters from Adata and Kingstone to be corrupt.

  • 3
    Nothing in the question says that the poster is using an adapter. – Philip Kendall Jun 5 '15 at 6:44
  • 3
    Nothing in the questions says that the poster isn't using an adapter. – Rene Sep 3 '15 at 8:32

Your camera is clearly broken since the same problem is exhibited with multiple cards.

Since repair from Nikon will be probably more than the camera is worth you should consider a local repairer. You can find them online or if you visit a camera store they will either be able to do the work for you or be able to put you in touch with a reliable repairer who can do the work for significantly less than Nikon would charge.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.