5

I hope it's not too OS specific/non-photography techy for this forum but I wonder if other 6D users have this problem and I just want to get my workflow improved:

I formatted a fresh Sandisk Extreme 64GB UHS-I card in my new Canon 6d. When trying to import the photos from my card under Linux with my all-time favorite photomanagement app digikam, I noticed it didn't get automounted and the format was infact exFAT (although I read the 6D only formats cards >=256GB in exFAT):

mount: /dev/sdc1: more filesystems detected. This should not happen,
   use -t <type> to explicitly specify the filesystem type or
   use wipefs(8) to clean up the device.

So I mounted it by hand, which worked fine, but was cumbersome. I also noticed some buffer I/O errors in my demsg log: Buffer I/O error on dev sdc1, logical block 16, async page read

So I fired up exfatfsck on the device, which gave me no errors:

# exfatfsck /dev/sdc1
exfatfsck 1.1.0
Checking file system on /dev/sdc1.
File system version           1.0
Sector size                 512 bytes
Cluster size                128 KB
Volume size                  59 GB
Used space                   11 GB
Available space              49 GB
Totally 4 directories and 2642 files.
File system checking finished. No errors found.

Tried to inspect the card in partitionmanager but it didn't detect the filesystem type, either.

I wonder what's wrong with my card and how I can get my 6D to work better with my system, don't want to mount by hand every time (udev rules don't work since the card doesn't have a label and no UUID).

4

Just solved the issue by chance - I used exfatlabel to name my card and voilá it was auto-detected and works fine under Linux and in my 6d:)

  • Out of curiosity, did you have to use a specific label, or just any label at all? – mattdm Feb 15 '15 at 22:12
  • I doubt that "canon6d" is a special name;) So any name should do, it just needs a label. Maybe exfatlabel corrects some other structural bogusity and cleans up the filesystem. Did you try with just exfatfsck? – Gregor Feb 23 '15 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.