1

I installed Magic Lantern on my Canon EOS M. Eventually the shutter is blocked and you can´t take a picture. The problem is more common with the 22mm F2.0 lens than with the 18-55mm lens. Does anyone know how to fix this problem?

  • Have you tried the Magic Lantern help forums? – dpollitt Feb 5 '15 at 21:24
  • With Magic Lantern--when in doubt--pull the battery out of the camera. – inkista Feb 6 '15 at 4:23
2

Temporary fixes seem to include partially dismounting and remounting the lens, or power-cycling the camera.

It looks like this is an actual bug in the EOS M build, and they're having a very hard time diagnosing what's going on, although they now suspect it's an issue with the bootloader. I'd suggest going to the thread on this bug and seeing if there's anything you can do to help, testing or debugging-wise.

0

I solved the shutterbug problem by simply using a better quality SD card, cheap kingston card, shutterbug, better Sandisk card, no shutterbug.

Also i only had the problem with the 18-55mm lens, not the 22mm

0

You can go to Custom Functions, and Enable Release Shutter w/o lens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.