2

I have used my Nikon D60 for about 6 years now, with AF-S DX NIKKOR 18-55mm f/3.5-5.6G, and AF-S 55-200mm Nikkor f/4-5.6G lens, and the autofocus has been working fine this entire time.

However, I recently used the AF Nikkor 50mm f/1.4D lens for a few days, which of course requires manual focus. But when I switched back to my two older lenses, the autofocus would not work anymore. The motors would rotate but it just wouldn't focus. In the past, if that happened, all I needed to do was detach and reattach the lens, but that didn't help. I tried to clean and wipe everything but still doesn't work.

Although I thought that initially putting on the 50mm lens was more difficult, as it felt like a tighter fit, and now it feels much easier to put on my older two lenses, and it just feels looser. Could it have anything to do with that? like a problem with the contact between Camera and Lens?

Any thoughts? Much appreciated on any suggestions!

  • 1
    After you used the 50, did you set the camera back to AF, or is it still set for manual? – Blrfl Feb 3 '15 at 18:46
  • Are you referring to focus settings (AF-A, AF-S, AF-C, M)? Then yes, it is set on AF – Yitian Tao Feb 3 '15 at 20:28
  • 1
    Let me ask the obvious questions first. Have you changed back from manual focus to autofocus in the menu? Have you set the AF lenses to AF? – Jeff Watson Feb 9 '15 at 14:40
  • Yup, all set to AF. The motor still rotates back and forth on its won but doesn't focus and the shutter won't release, thanks – Yitian Tao Feb 12 '15 at 14:51
  • 1
    So you can see the focus ring on your 18-55 rotating, but the camera never achieves proper focus? It sounds like the camera cannot detect when the image is in focus anymore. What happens when you turn on the rangefinder (page 116 in the manual) and set the lens to manual focus? Does it ever indicate correct focus as you are focusing manually? If not, there may be a problem with the AF system. – Szabolcs Feb 18 '15 at 3:01
1

I just encountered this exact problem. I followed the instructions of other posters and found nothing helped. However I dd pop in a fully charged battery and the auto focus resumed working as normal. I have used the camera many times and even ran the battery till the shutter would not operate and the camera's display requested to charge battery with out having any issue with auto focus. the only thing different is that it is much colder today. My suggestion is to charge the battery and try the autofocus again before taking any more drastic measures

-1

Reset the camera to factory settings. Press-and-hold the two buttons marked with a green dot.

-1

It sound like you may have damaged one of the points, since you say the 50 no goes on without a problem and your other lense feel loose. Check all the points and see if you have damaged the connecting ring on the camera, if these are damaged then no resetting will work you will have to focus manually from now on, to get them fixed is way to expensive it would be cheaper to replace your D60, am still using a D60 and I used a sigma 50 prime and I had no problems all my other lense work in auto focus. So check the points and fingers crossed they are not damaged.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.