6

I've just received 2 pieces of Yongnuo YN568EX for my Nikon D610. When I’m on I-TTL mode the flash fires but the image is black (I tried it on each mode: auto, manual, A…), the sound tick-tick twice-tick twice can be heard – “ the speedlite is in the charging or overheating protection state”. It seems that the flash is not synchronized with my camera, even if my older Yongnuo YN565EX is working perfectly with the same settings of my camera.

When I’m using it in M mode the picture is good, but even if I put it to 1/1 or 1/128 I have the same output power. Both of my flashes have these issues, so I guess that I’m doing something wrong.

Any idea on how to solve the above?

7
  • What shutter speed are you using? high-speed-sync tag implies something faster than 1/200th?
    – MikeW
    Jan 20 '15 at 22:03
  • 1
    Are the serials close or the batch numbers the same? I wouldn't be at all surprised to see 2 from the same batch have the same issue. You mentioned that you have an older Yongnuo so you should be familiar with how they work and it sounds like you've read the manual.
    – alex
    Jan 21 '15 at 1:12
  • 1
    Do you have the older 568EX or the current 568EX II? The older 568EX comes in separate Nikon and Canon variants. What you are describing sounds like you may be trying to use Canon variants on your Nikon camera.
    – Michael C
    Jan 22 '15 at 0:40
  • 3
    @MichaelClark slightly easier way to find out the brand-version is to ask if the lettering on the flash is silver or gold. Gold=Nikon version; silver=Canon version.
    – inkista
    Jan 22 '15 at 5:06
  • @MikeW, I tried from 1/60 to 1/250 - no changes. Jan 23 '15 at 20:09

Browse other questions tagged or ask your own question.