2

The first time I played around with Ufraw / Gimp on my Windows machine, I hit "save" in Ufraw. Now, it opens every new photo with the odd warm settings I was playing with. How do I reset Ufraw to just open the photo as it is?

I have uninstalled, restarted, reinstalled multiple times now.

Another thing I've tried is creating a new profile. It seems as though it is not tied to a user account but something system wide.

I was able to regenerate a new .ufrawrc file by saving new settings in there. If I rename / delete this file, the settings are still saved in the application somewhere. Here is the contents of my file:

<?xml version="1.0" encoding="utf-8"?>
<UFRaw Version='7'>
  <WB>Manual WB</WB>
  <WBFineTuning>0</WBFineTuning>
  <Temperature>5187</Temperature>
  <Green>1.056</Green>
  <ChannelMultipliers>1.9245 1.0000 1.3705 1.0000</ChannelMultipliers>
<Exposure>0.333333</Exposure>
<BaseCameraCurve Current='yes'>
</BaseCameraCurve>
<LinearCurve Current='yes'>
</LinearCurve>
<MatrixInputProfile Current='yes'>Color matrix
</MatrixInputProfile>
<sRGBOutputProfile Current='yes'>sRGB
</sRGBOutputProfile>
<SystemDisplayProfile Current='yes'>System default
</SystemDisplayProfile>
<Make>NIKON</Make>
<Model>D3300</Model>
</UFRaw>

Maybe someone can give me the contents of their unedited file and I can try to copy/paste some of the values?

  • Alternatively, if you can recommend something better to view NEF's on windows, I'd be open to that. – Jeff Jan 4 '15 at 20:33
2

The config file of Ufraw is located in %USERPROFILE% and it is named .ufrawrc

You can delete or rename this file to reset your current settings

P.S. There is a dot as first symbol in filename

  • I've edited my question. I removed the file, and it kept the messed up settings. I've also created a new profile to test if this was this issue. Is there another place this file is stored? – Jeff Jan 6 '15 at 17:24
  • @Jeff, have you stop the ufraw before remove the file? I test exactly this and w/o stopped ufraw i get saved values. But when I stop it, remove again the .ufrawrc and start again it show me the default values (i play with colour temperature) – Romeo Ninov Jan 6 '15 at 17:42
  • Is ufraw a service? What do you mean stop? – Jeff Jan 6 '15 at 20:56
  • No, this is just ordinary program. Better stop gimp and ufraw and then remove the file. And check if there is (eventually) some zombie process of ufraw – Romeo Ninov Jan 7 '15 at 5:07
  • 1
    I am saying I have tried this, the file is no longer there. – Jeff Jan 7 '15 at 13:07
0

The nUFRaw (https://sourceforge.net/projects/nufraw) is a new UFRaw version which has an handy button to reset all values. It's still in beta but you can try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.