2

I recently purchased a Canon EOS Rebel DSLR SL1. My 18-55 mm lens shoots amazingly, and I have been using it in auto and manual focus. About a week ago, my manual focus randomly stopped working. The auto focus still works perfectly, which confuses me. Though I move the focus ring in manual, it won't change the picture at all. Is there anything I can do without having to send it in to be fixed?

  • There are few different 18-55 lens from Canon. Which one exactly is yours? And have you try to use AF/MF switch on the lens? Its not sure your lens is full time manual focus – Romeo Ninov Dec 26 '14 at 22:09
  • 2
    Some lenses (like the Canon f/1.2L II USM) only do manual focus when the camera is on. And some accessories (like cheap extension tubes) sever the electronic connection between the camera and lens. Which lens model exactly are you using, is your camera turned on, and are you using any accessories? – l0b0 Dec 26 '14 at 22:39
  • 1
    What exactly do you mean it stopped working? Can you take a picture in manual mode? Do you have sufficient light? Are you positive? What priority mode is selected on the dial up top? – dpollitt Dec 27 '14 at 3:35
  • May I ask, which lens do you have? Different lenses perform differently. – Cullub Feb 27 '15 at 17:10
1

The current standard kit lens with the SL1 appears to be the STM version which means, among other things, that the camera has to be powered on and ready to shoot (not sleeping) for manual focus to respond. Essentially it's a "focus-by-wire" system, where there isn't a direct physical connection between the focus ring and the actual lens elements, instead the focus ring controls the stepping motor that moves things back and forth to focus the image. If that is the version you've got, then I'd try a couple things to debug the problem.

First I'd make sure that the camera is on and not asleep (push shutter button part way to wake it up). Then if it's still not working, try the same lens on a different Canon camera (any crop sensor DSLR, such as any of the rebels, should work.) If it still doesn't work, then there may be some problem with the lens. If it does work, there may be some problem with the camera body. Either way, you'd need to take it to a professional to get it evaluated/fixed.

If it's not an STM, and you're sure you've got the focus switch on the lens set to manual, and if it's not working, again you'd need to take it to a professional.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.