6

I have some old photos on the SD card in my Sony A57. After importing into Lightroom, there are horizontal artifacts on most of the imported photos. This is a screen grab of Lightroom displaying one of the photos.

pic

I have tried this import multiple times with the same result. I shoot in RAW + JPEG. The equivalent JPEG image also doesn't seem to render properly - it just cuts off drawing a certain amount vertically.

The import spans multiple shooting sessions across months, so my guess is that the corruption is occurring in the import process. The photos seem to render fine on the camera display.

I just imported some newer photos yesterday and didn't notice this.

What could be the cause? How should I go about troubleshooting? Is this a bad SD card? Bad data cable?

Should I assume the data on the card is bad (i.e. photos are not recoverable)? Or is this most likely a problem in the import process somewhere?

Should I stop using this SD card at this point?

Update: It is not the mini USB cable that I was using. I cannibalized one from a PS3 controller and the import still had the same symptoms.

  • 1
    Have you tried with a different RAW converter? Whatever Sony supply, or DarkTable or something? – Philip Kendall Dec 16 '14 at 13:58
  • I'm afraid I don't even know how to switch out RAW converters. I'm just using whatever was baked into Lightroom. It has worked flawlessly prior to this import. – RationalGeek Dec 16 '14 at 14:05
  • 2
    Use a different app entirely :-) – Philip Kendall Dec 16 '14 at 14:06
  • Have you tried copying them manually to the hard drive and then importing from that location? I have a similar issue with one of my SD cards... not sure what is the reason, but in my case, the issue occurs on that single SD card only... (Sorry I would comment on your original post, but don't have enough rep) – S. M. Dec 16 '14 at 14:15
  • 4
    Based on symptoms for me it is a bad SD card. But nevertheless try to zoom the photos on camera display and check for these artifacts. And do not keep photos on SD card. Get the habit to copy them on computer after each shooting session – Romeo Ninov Dec 16 '14 at 15:35
1

You asked "How should I go about troubleshooting?"

I would do something like the following:

  1. Copy all images from SD card to another location (so you are working with copies and don't risk damanging your originals).
  2. View images in new location using Windows File Explorer, or Mac equivalent. If the Operating System is showing the lines, then the photos are likely already corrupt before touching Lightroom.
  3. Export one of the corrupt photos from Lightroom to jpeg and check whether the jpeg shows the corruptions in File Explorer or equivalent - this is testing whether the issue is just with Lightroom rendering the image within the application.
  4. Import the images to a different computer. This is testing whether the first computer's video display functionality has a fault (such as corrupted drivers or hardware fault). If the stripes still appear, then the issue is not likely due to video card or drivers.
  5. Take new photos onto same SD card without formatting the card. If new images don't have the issue then it's unlikely lightroom - more likely a corruption to your old data.
  6. If new images do have corruption then use the same camera with different SD card and import again. If these images do not have stripes, then it's likely the SD card. If they do, then it's not your old SD card.
  7. If those images did have corruption, then you could test your import cable or SD card reader by swapping it out with another one, but I would expect it quite unlikely to be the source of the problem, and at this stage would suspect the Lightroom software to have an issue. Search for updates to your Lightroom software and install them, then try again.

Failing the above I would have to think it through in a bit more detail.

  • I wouldn't be so quick to rule out the flash card reader. This looks a lot like the corruption caused by a bug I've seen in some really old USB flash card readers on old versions of OS X. If it happens to be the same bug (caused by the flash reader barfing on multiblock reads), it is fixable by using dd to clone the flash card to your hard disk using the default 512-byte block size. – dgatwood Feb 5 '17 at 4:29
0

I can't comment yet, sorry.

Did your images ever go into LR 4?

I had the same issue with photos that went through Lightroom 4. There was an issue with LR4.2 through 4.4 that caused corrupt photos. This may or may not be your issue, but you mentioned these photos are very old. I had lots of my files that were affected and it was only luck that I noticed it while I still had backups. I replaced the images and updated LR and haven't had similar issues since. I now keep 2 backups of all my photos.

Here is some info about the LR 4.2 > 4.4 bug. I had photos that had blocks missing, but I also had some that had the lines you are showing here.

Google Search revealing lots of info on the LR4 issue: https://goo.gl/NLdAa2

Unfortunately in my case I was not able to fix the images and had to recover from a backup. Sorry to see the damage, looks like nice photos. You could maybe content aware the individual lines out as a last ditch effort.

protected by John Cavan Mar 18 '15 at 16:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.