2

I bought a new Nikkor 50mm AF-S 1.8G to add to my Nikon D3200, however, it will not recognize the lens. It says "Lens Not Attached" in all modes with error "NON CPU lenses can only be used in manual mode". The AF-S lens is a CPU lens and compatible in all modes with D3200 (as per the spec). Even in Manual mode, I cannot change the aperture and it shows "F - -", which is an error.

I thought the lens is bad, so I bought another lens from a local store and it behaves the same. So I took my friend's D7000 and the 50mm lens works fine with it, so the lens is not bad. The other lenses I have are the kit lens 18-55 VR and 55-200 VR and they both work fine with my D3200, so its not that the camera is bad either, its just the combination of D3200 with 50mm and trying 2 new lenses with the same D3200, I am puzzled.

What could be the problem?

  • Please clarify what you mean by this: "and trying 2 new different D3200". Did you try with one or two D3200? – TFuto Nov 4 '14 at 20:29
  • I mean trying 2 new lenses with the same D3200 – user3893309 Nov 4 '14 at 20:36
  • 1
    Update: Sent the camera to Nikon, they claimed the bayonet mount is the issue and asked for $160 to replace. On further discussing with them, they did the replacement for free under warranty. I received the camera and is now working fine. – user3893309 Dec 23 '14 at 23:41
1

Have you tried cleaning the contacts of the body? It may be that the clearances are different between lenses, so the zooms apply a stronger force on the contacts.

It is obviously the body is at fault as two of the same lenses did not work. And there is a difference between the 50mm contact/lens mount and the zooms. Also, the 50mm works with the D7000 - so, your body is at fault most probably.

Another issue could be: D3200 firmware does not support the lens. Highly unlikely, but has happened. Check that you have the latest firmware on the D3200.

  • yup, have cleaned the lens and body contacts. will check the firmware, if there is newer version. i have the same feeling that the body is at fault, but the weirdness is that other lenses i tried with the body, they worked (18-55, 55-200 and now even 1.8/D ) – user3893309 Nov 4 '14 at 20:38
  • 2
    just checked. the firmware is also latest C:1.01 – user3893309 Nov 4 '14 at 20:41
  • @user3893309 The latest firmware is 1.03 (link) – skuroda Nov 5 '14 at 20:58
  • @skuroda, thanks. It was only showing 1.01 from My Nikon page, will give it a try tonite and see if that helps. – user3893309 Nov 6 '14 at 2:18
  • Tried to upgrade to 1.03, still same issue. might have to send it to Nikon under warranty – user3893309 Nov 6 '14 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.