4

I'm new to Lightroom 5. To learn I tried to take an existing photo and improve it in the Develop module. I exported the results but the color cast is different in every other JPG viewer and browser from what I see in Lightroom. Even after adding the export to the Lightroom library and opening it in Lightroom it continues to look like what I had Developed. Why is Lightroom rendering images with different colors than everything else? I'm guessing there's a gamut adjustment somewhere I need to disable but can't find. In the export settings I've tried both the sRGB and AdobeRGB (1998) colorspaces with the same results.

Here is the original, followed by the developed image export as seen in Lightroom (via screenshot), and then the same image viewed everywhere else:

Original: enter image description here

Developed and viewed in Lightroom (screenshot), including exported and reimported enter image description here

Developed Export in any viewer: enter image description here

  • In my case this problem appeared as a distinct purple colour cast. I mention it here in case it helps someone google it. – RoG Oct 25 '17 at 17:41
4

Apparently this was the result of an improper OS-level color management setting. Following these instructions fixed it!

Windows

  1. Close Lightroom.
  2. Go to Start menu > Control Panel > Color Management.
  3. Click the Devices tab if it’s not already selected.
  4. From the Device pop-up, select your monitor. If you have more than 1 monitor connected, pressing the Identify monitors button will display a large number on screen for identification.
  5. Check the ‘Use my settings for this device’ checkbox.
  6. Make a note of the currently selected profile, which is marked as (default). If there isn’t an existing profile, you can skip this step.
  7. Click the Add button.
  8. In the Associate Color Profile dialog, select sRGB IE61966-2.1 (sRGB Color Space Profile.icm) and press OK.
  9. Back in the Color Management dialog, select the sRGB profile and click Set as Default Profile, and then close the dialog.

Mac OS X

  1. Close Lightroom.
  2. Go to System Preferences > Display.
  3. Select the Color tab.
  4. Press the Calibrate button and follow the instructions.
  5. Turn on the Expert Options and calibrate to gamma 2.2.
3

Most probably the JPEG has a color profile inside which is taken in account by Lr but ignored by other JPEG viewers. To check if this is the case download any free JPEG viewer which supports ICC and look at the image with and without ICC support.

If you don't know any such viewer (as it seems) here are the steps:

  1. Download XnView MP (it is free)
  2. Go to Tools | Settings | General | ICC

Case a) :

  1. Make sure that "Use ICC profile..." checkbox is UNchecked
  2. Close, navigate and look at the file (press F11 for Full Screen or, alternatively, double click on the file to open it)

The file should look in the same manner with your "any viewer" case.

Case b) :

  1. Make sure that "Use ICC profile..." checkbox is checked
  2. (optional) for the first try leave the ICC options at their defaults. ('system ICC' etc.). If it doesn't work change them for the next try.
  3. Look at the file in a similar manner with the step 2 from Case a).

  4. If the file doesn't look like in your "Lightroom" case, go to step 2, change settings and retry.

  • OK, tried that and not seeing any difference. The first (original) and last JPEG in the question (the Lightroom export) are unmodified so if there's any doubt you should be able to check if I'm missing something. The first has no embedded color profile. The last does have an "Embedded Color Profile" called "sRGB IEC61966-2.1" but whether it is used or not it doesn't change what I see, which is still significantly different from what I see in Lightroom. In any case I don't think I want Lightroom adding profiles to exports so if you can tell me how to do that it might address half the Q. – feetwet Jul 28 '14 at 3:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.