I have a Nikon D5100 and I have converted my NEF files to JPEG using the Nikon software "NEFCDC". The pictures got converted, however, they developed a green tint in them. Please help me out converting the pictures without the green tint. I have tried the Adobe software and it gave me the same problem. I first used the memory card reader to transfer pictures into my laptop, that has Windows 7, and then tried with the USB cable that came with the camera. Anybody could help me out, please?

6 Answers 6


This kind of thing can happen if your NEFCDC is out of date, since it needs to be updated for every new camera that comes out.

If that doesn't work then try opening the NEF with with the View NX or Capture NX 2. Each NEF image includes a JPEG preview image. If the embedded JPEG preview has a green tint, then the NEF will too.

You can also get a green tint if your camera's white balance is set for sun and you shoot with a florescent light source. Try mixing and matching "incorrect" white balance settings, it can be quite fun.


You are converting a RAW file, which contains far more color information a JPEG image can store. So the usual RAW-to-JPEG flow is to open CameraRAW or Lightroom, and manually adjust white balance, tinting, contrast, etc. and then you can save the corrected image to a JPEG. Without providing these parameters, the NEFCDC will just guess, and usually you end up with incorrectly "developed" images.

Your issue is not related to file transfer.

What Adobe software have you tried?

And finally, there is an additional issue: color management. If you store images without embedding your ICC profile (or if you work in an unmanaged environment), JPEG preview will show a very different color in different viewing conditions, on different platforms.

Try to do a conversion to plain sRGB, without embedded ICC, and see if that fixes your color issue.


try the free Capture NX-D from Nikon's website. There you can adjust the photos before exporting them

enter image description here


Make sure to rule out the obvious: that your monitor is incorrectly calibrated. Try viewing the images on another computer, or attach an external monitor to your laptop. If possible, try printing a sample with a reputable printing company. Is it still green? Ok, then the conversion is the problem. If not, you have a problem with what your monitor is displaying.


Use Photoshop Raw editor and set it to sRGB and leave all other settings the default. Current option is at the bottom of your screen. Took me a while to figure it out and it works 100%


Use appropriate software to manage all your images. The best application out there is Lightroom, in my and many others opinion. This kind of software doesn't need to convert the photos to JPG. You can just use the NEF files as they come out of your camera, in order to maintain all the detail. Tweaking colors is done easily this way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.